Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Simulate physics not working in BP

Hi. I have a problem. In my BP, (Actor) I have scripted the hay to simulate physics when activated. The physic work if sent manually, but that's no use. I'm using 4.14.

BP : alt text

The model has working collisions, so I just think its the BP going wrong.

Product Version: UE 4.14
capturenodes.png (210.2 kB)
more ▼

asked Apr 03 '17 at 02:00 PM in Using UE4

avatar image

Virtual Bones
10 3 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ok, so I just encountered the same kind of problem. I can't set a mesh to simulate physics through BP and can only set it through editor properties. But I solved it. What I did was I went to the Physics Asset the mesh is using and set the "Physics Type" property of the collision bodies to be "Default" instead of "Simulate". Now I can enable and disable physics simulation at runtime through BP.

Note to devs: I think it must be mentioned somewhere in the "Set Simulate Physics" function's description.

more ▼

answered Jul 15 '18 at 11:53 AM

avatar image

63 3 6 9

avatar image gamesmyth27 4 days ago

Hnomer could you be more specific? Screenshots maybe? I can enable physics from the editor window including gravity but I cannot enable from the BP.

avatar image Hnomer 2 days ago

You must open the Physics Asset editor, then select a collision body from the hierarchy, then you should be able to see the Physics Type property on the Details panel which is by default should be on the right side of your screen. Set the Physics Type to Default (see screenshot). After you're done with this, you should be able to change Physics settings using SetSimulatePhysics node. Note that it will only change the behavior of the collision bodies with Physics Type set to Default. I honestly don't know how I can explain it better.

alt text

untitled.png (44.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It's hard to tell what the nodes are trying to do. But by looking at the image, I can see you only have one SetSimulatePhysics node and it's set to always False.

Also, you sure your mesh is not set to Static or Stationary on the mobility options? In 4.14 and after, those mobility options also affect movement, not just baked light and shadow calculations.

more ▼

answered Apr 03 '17 at 02:37 PM

avatar image

630 58 65 306

avatar image Virtual Bones Apr 03 '17 at 06:49 PM

Thanks, because of you I managed to pinpoint the problem. It turns out that "Q" button press is not working.

avatar image Motanum Apr 03 '17 at 06:52 PM

You can select the Q node and press F5 to add a break point. When you play in editor and press 1, the game will pause and show you the q event, and you can go step by step and see what is being executed.

If you add the break point and in fact it is not being halted, then you know it was that that is the issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question