x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Character switching to t-pose for single frames

Hello,

I just upgraded to 4.15.1 and I found a weird issue: when standing in idle with my character, the animation plays normally, but sometimes (seems to be random) my character switches to t-pose and back for one frame. Sometimes this "flickers" for a few seconds and then not anymore for minutes. Does anyone know this problem and has a solution for me? Would really appreciate this, as I searched all my blueprints and did not find an error!

Thanks in advance :)

Product Version: UE 4.15
Tags:
more ▼

asked Apr 04 '17 at 08:28 AM in Bug Reports

avatar image

TP-STUDIOS
1 1 2 4

avatar image Matt.Williams Apr 05 '17 at 03:42 PM

Hi Tibon,

A little more insight into how you have your character, AnimBP setup, blendspaces, etc would really help in debugging this issue. Is it just the standard 3rd person template character that you're seeing this with?

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Tibon,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

-Matt W.

more ▼

answered Apr 10 '17 at 08:50 PM

avatar image TP-STUDIOS Apr 12 '17 at 06:34 AM

Hi, sorry for the late answer. We've not found the bug yet, but it seems to depend on the map you are playing on and maybe the pc, too. I think there is not much left from the standard third person character, since we made an own animBP, multiple characters, that inherit from the thirdpersoncharacter and also an other player controller. So there are lots of possiblities. I tried all the different characters, from the most simple one to the most complex and it seems to happen with all of them, so i think it's not a characters fault. Maybe it's the anim BP but I have no idea on how to find, where the bug is hiding. What could also be helpful is, that it seems to only happen when in idle. Idle state is also a single state, so no blendspace to jogging.

Thanks for you help!

avatar image Matt.Williams Apr 17 '17 at 09:05 PM

Hey Tibon,

Are you familiar with the debug filter in Blueprints and AnimBPs? I'd suggest you play in editor and switch the debug filter to show your active character. This way you can see exactly what's happening throughout the event and anim graphs. I'd suggest also using the "Watch Variable" feature by right clicking on a pin and selecting "Watch". If you're doing that already, we can dig in further.

If it's only in Idle, I'd concentrate on the locomotion state machine, if that's how you have yours set up. Most people have a base locomotion and build from there.

-Matt W.

avatar image TP-STUDIOS Apr 18 '17 at 06:11 AM

Hey Matt,

yes that's right, I use a locomotion system, but I have 13 states, instead of the standard 4 or 5. As far as I know, there is nothing visible when using the debug filter...I think there should be a change or something when it happens, right? I did not use the watch variable function yet, because I don't know on which variable to use. Do you have any suggestions, how I could guess the right one?

avatar image Matt.Williams Apr 28 '17 at 04:55 PM

Hey Tibon,

At this point, it might be best to get an example project. You can migrate your character over to a blank project or send me the whole thing, but you'll need to PM me a download link on the forums if you want to keep it private.

-Matt W.

avatar image TP-STUDIOS May 02 '17 at 11:38 AM

Hey, thanks for your answer again. I solved the problem: it was because of a SetMasterPose I used on tick. Don't know why, but I had to do this some time ago, because it didn't work when using only on init. But that solved it for me :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question