x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Materials not loading in when opening project

I'm working on a game in a research lab with some peers and we attempted to finish up the Alpha this weekend. They built the game and got a lot of compile issues with materials that came on marketplace foliage packs that we purchased. Below is the log.

https://docs.google.com/document/d/1UfqoxdZ1eOBzKDnkvzHrzVViKDFY3uNi7ICP7d3nNp0/edit?usp=sharing

Today I got into the file to see if I could figure out what was going on with that and was greeted by new errors :( The message log contained 247 load errors and they seem to all be material based, and not the materials that were popping up in the previous log.

alt text

alt text

As far as I know the materials haven't been moved/they're still in the same location that they were when I was working with them last week. I'm at a loss here and I'm really new to unreal, so I'd really appreciate any and all help. Thanks in advance.

Product Version: UE 4.13
Tags:
messagelog1.png (168.6 kB)
messagelog2.png (119.1 kB)
more ▼

asked Apr 04 '17 at 05:08 PM in Using UE4

avatar image

rrr1206
6 1 2 2

avatar image AndrewHurley Apr 05 '17 at 03:07 PM

Hey rrr1206,

These referencing errors usually occur if you have upgraded a project or migrated content. Try renaming you project to something different if you upgraded it from a previous version. You can also right click on your 'Content' folder within the content browser and fix up redirectors. Make sure all the textures it is saying is missing, are in fact there and not missing. This is not an engine bug, but expected errors and warnings with bad references. Head to our documentation to learn more.

Cheers,

Andrew Hurley

avatar image rrr1206 Apr 06 '17 at 07:51 PM

I've tried the "fix up redirectors" on the folders and I've tried renaming the project. Everything is still broken when I open up the project :( Is there anything else that it could be?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try removing your Saved and Intermediate files from your project's directory to see if that resolves most of the referencing issues. Be sure to make a copy of these folders first before deleting/removing them from our project.

Let me know if you need further assistance.

Cheers,

Andrew Hurley

more ▼

answered Apr 09 '17 at 03:21 PM

avatar image rrr1206 Apr 10 '17 at 03:32 PM

So I copied the Saved and Intermediate files, then deleted them and reopened the project. The referencing issues disappeared, but now all of my textures aren't in the project at all. All the materials I imported are there, but the individual maps are missing, which is what I need.

avatar image rrr1206 Apr 10 '17 at 06:27 PM

I just reimported all the textures again as individual bitmaps, as opposed to the .sbsars and reapplied them and they are working again. But I'm afraid that when they try to build again, they'll break again :(

avatar image AndrewHurley Apr 11 '17 at 04:28 PM

Well you have already done the hard part. Run a Map Check within the 'Build' dropdown settings to make sure your errors/warnings are being cleared.

I am going to mark this as resolved for tracking purposes.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question