x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fatal Error: d3d11?

When ever l launch Unreal Engine 4 l get this fatal error message (Similar error with Squad SDK).

Things l have tried;

  • Complete re-installation of graphics card drivers

  • Complete re-installation of Unreal Engine

Updated Information;

  • Lastest AMD drivers installed, previously installed was 16.12.1 and issue still persisted

  • Re-installation of Direct X

  • The game Squad has zero issue and doesn't crash

  • Tried Administrative rights

I tried searches for similar issue but couldn't find anything.

Dxdiag: link text

Image of error with Squad SDK;

alt text

LoginId:fb573bc04076aa85a942bc997864a89f EpicAccountId:c2eee09067474e28a313b96d1fc632d8

Fatal error: [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 227] SwapChain->ResizeBuffers(1,SizeX,SizeY,GetRenderTargetFormat(PixelFormat),DXGI_SWAP_CHAIN_FLAG_ALLOW_MODE_SWITCH) failed at D:\Build++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:219 with error DXGI_ERROR_INVALID_CALL

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:349] UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:227] UE4Editor_D3D11RHI!FD3D11Viewport::Resize() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:221] UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::ConditionalResizeViewport() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:399] UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindows_Private() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:1000] UE4Editor_Slate!FSlateApplication::PrivateDrawWindows() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1419] UE4Editor_Slate!FSlateApplication::DrawWindows() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1115] UE4Editor_Slate!FSlateApplication::TickApplication() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1720] UE4Editor_Slate!FSlateApplication::Tick() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1512] UE4Editor!FEngineLoop::Tick() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:3086] UE4Editor!GuardedMain() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\launch.cpp:166] UE4Editor!GuardedMainWrapper() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:134] UE4Editor!WinMain() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:210] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

Product Version: UE 4.15
Tags:
capture.jpg (39.2 kB)
dxdiag.txt (89.0 kB)
more ▼

asked Apr 05 '17 at 02:42 AM in Installation & Setup

avatar image

dadey60
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Unsure what was causing the issue but creating a new windows user profile and launching unreal engine on the new account seems to have fixed the issue on my main windows account.

P.S. not sure where l go to resolve this issue so l'm just going to up-vote this comment

Edit: Can't up-vote myself

more ▼

answered Apr 10 '17 at 10:53 AM

avatar image

dadey60
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

According to this:

forums.joinsquad.com/topic/10297-fatal-error-on-start-up/

You need to update your graphics drivers.

more ▼

answered Apr 05 '17 at 12:02 PM

avatar image

MrGoatsy
604 34 26 45

avatar image dadey60 Apr 05 '17 at 10:49 PM

Thanks for your help but l already have the latest AMD drivers installed (Beta) which the previous driver l had was 16.12.1 and the issue still persist.

I should've mention that the game itself (Squad) has zero issue and doesn't crash, It's just the Editors l am having issue with.

Also just tried reinstalling Direct X and the issue still persist

(Will add all this to main post)

avatar image MrGoatsy Apr 06 '17 at 12:54 AM

Please try to run it with administrative rights.

avatar image dadey60 Apr 06 '17 at 01:15 AM

Issue still persist, starting to think that it might be more hardware related not drivers but l don't have any extra RAM or graphics card laying about to test.

Adding administrative rights to main post

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question