x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Things Disappearing in VR

I'm having a weird problem. Seems like maybe a bug. I'm prototyping this Archer shooting gallery game, where animal targets move around the scene on tracks. It all is seemingly working fine. When I hit simulate, everything moves around the tracks as it should. However, as soon as I view it in VR, something strange happens. The Bear and the Deer disappear. The first dear goes by, but the other 3 never come. And the bear goes into his cave and never comes out. If I delete the front of the bear's cave, so I can see him the whole time, he goes in and out as he should. But if the cubes are there, and he leaves my view, he never comes back out. I can perform a similar test with the deer. It's almost like it's doing some culling but then forgets about them or something. Anyone ever experienced something like this?

alt text

alt text

Product Version: UE 4.15
Tags:
exhibit a.jpg (333.8 kB)
exhibit b.jpg (254.0 kB)
more ▼

asked Apr 05 '17 at 06:31 AM in VR

avatar image

emomobile
5 2 2 5

avatar image emomobile Apr 05 '17 at 07:49 PM

So I turned off Culling in my project render settings, and that solved my problem. However, my new problem is that I imagine that will give me pretty significant performance hits when I start to build out my level with final artwork. Now that I know it's a culling issue, is there something I can do to fix it besides turning off culling completely?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

have you tried creating a Cull Distance Volume?

more ▼

answered Dec 06 '17 at 01:14 AM

avatar image

Spectral Ink
219 10 12 23

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question