x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

"Hard edges" on a smooth mesh

The issue is simple but I have no clue as to what's causing it, here's how it goes.

First I'll make a smooth shaded mesh in blender (I'm using the 2.78 version) alt text

So in order to import it to UE4, I'll export it to FBX, with smoothing set to face, and tangeant space enabled. Then right click into the asset browser in the Unreal Editor, and import it with its normals and tangeant space. So far so good. But alas, something has to be wrong, because the mesh now gets some not-so-smooth edges. alt text

I personally do not have a single clue as to why this is happening. I've tried changing every parameter that I mentioned earlier (smoothing normals/face/edge ; building the normals instead of importing them...) and so far I've gotten the same result every time. What could I have missed ?

Product Version: UE 4.15
Tags:
4dcf979670.jpg (31.5 kB)
0d2b2cf433.jpg (61.4 kB)
more ▼

asked Apr 05 '17 at 04:06 PM in Rendering

avatar image

MatryoshkaMAiD
3 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Ticking "Loose edges" in geometry when exporting seemingly fixed it.

more ▼

answered Apr 05 '17 at 05:00 PM

avatar image

MatryoshkaMAiD
3 1 2 5

avatar image Spiffy262 Apr 05 '17 at 05:10 PM

I'm glad you found the solution, I should use blender more often!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, are you using this to smooth the mesh in blender? https://docs.blender.org/manual/de/dev/modeling/modifiers/deform/smooth.html

The deform modifier does not change the vertices of the model. From the docs: " It smooths without subdividing the mesh - the number of vertices remains the same."

Basically you need to run a smooth that actually adds vertices. Good luck because I don't know Blender well :( (this has a very easy solution in Maya!)

more ▼

answered Apr 05 '17 at 04:30 PM

avatar image

Spiffy262
3 2 3 4

avatar image MatryoshkaMAiD Apr 05 '17 at 05:01 PM

"smoothing" refered to smooth shading, not the modifier or the tool.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question