x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disable Mouse Cursor Completely

Here is my problem. I have "Show Mouse Cursor" disabled in my Player Controller, but whenever I interact with a widget(like a button) the mouse cursor becomes visible.

  1. One solution I have found is by calling the Set Keyboard Focus function whenever I interact with a widget that has "is focusable" disabled. This spits out a warning each time you do it though, so its not exactly ideal.

  2. The best solution I have found so far is by setting the Cursor variable on the button widget to None and set the Input Mode to Game Only and then back to Game and UI each time I interact with a widget. I have to do the latter part of this solution or else the cursor will be visible when I move the mouse off the button. This isn't ideal but its a relatively easy fix.

My question is, is there a better or more proper way of completely hiding the mouse cursor when interacting with widgets?

Product Version: UE 4.15
Tags:
more ▼

asked Apr 06 '17 at 10:18 AM in Blueprint Scripting

avatar image

drb1992
268 7 23 31

avatar image Gameking002 Apr 06 '17 at 10:27 AM

Maybe try to do sometging in blueprint that once button is clicked the mouse cursor is immediately hidden again

avatar image drb1992 Apr 06 '17 at 10:32 AM

That is what I'm currently doing and will continue to do unless I find a better solution. It just feels like kind of a hacky solution and I'm just asking if anyone knows of a better solution than the ones I mentioned above.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

According to this question:

https://answers.unrealengine.com/questions/305828/umg-i-cant-hide-the-mouse-cursor.html

You need to do this:

You need to go GetPlayerController -> bSetMouseCursorVisible = false when the second map starts, probably in hte level BP BeginPlay event to keep it simple.

Please mark this as the answer if it fixed your problem.

more ▼

answered Apr 06 '17 at 11:14 AM

avatar image

MrGoatsy
604 35 27 45

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question