x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Any change made in Widget crashes project after restart

For some reason one widget crashes an entire project - but not instantly but only when restarting the project (I had the same problem with other widget). It seams it doesn't matter what I change to trigger this (I event disconnected all nodes and it still crashing).

The widget is used as a widget component within Character BP (it is a Cross-hair to be exact).

Also for some reason deleting widget component on this Character BP also causes such crashes. It's like I can't do anything with those widgets any more.

Product Version: UE 4.15
Tags:
more ▼

asked Apr 09 '17 at 03:03 PM in Bug Reports

avatar image

Gomo
91 5 6

avatar image vanlacke Apr 09 '17 at 04:54 PM

Crash logs?

avatar image Gomo Apr 09 '17 at 07:13 PM
crashlog.rar (215.7 kB)
avatar image Rudy Q ♦♦ STAFF Apr 10 '17 at 02:13 PM

Hello Gomo,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any settings/blueprints/widgets that may be involved with this issue?

  4. Was this project upgraded from an older version of the engine?

  5. If so, could you try deleting your saved and intermediate folders before upgrading and see if the issue still occurs?

avatar image Gomo Apr 10 '17 at 07:05 PM
  1. I can't. From my perspective it is random - I recenty added new idget to this character so I basically reproduced all steps - it worked and at one point it started to causes crashes.

  2. No - look at 1.

  3. UMG Settings Use in Character Use in Character 2 Use in Weapon As you can see this setup is quite simple (I had to set location of this second widget in Weapon because it crashed even more)

  4. It was upgraded many times since 4.2 or 4.3.

  5. I've already upgaded it - I could try to revert to changes from before upgrade and thend switch back to 4.14 and then make upgrade - but as it could take long time, I'll try to wait, maybe you can make up some better solution after reading what I provided in this post.

avatar image Rudy Q ♦♦ STAFF Apr 11 '17 at 02:46 PM

Hello Gomo,

Could you provide a stripped down version of your project that still reproduces the crash so that I could take a closer look? If you would like to provide it privately, you could do so by sending it via a drop box or google drive link in a private message on the forums.

avatar image Gomo Apr 11 '17 at 07:20 PM

I'll try to prepare something like that but maybe in a few days as it will probably take some time - last time I tried to do migrate of my Main Character almost all my blueprints and related content was migrated.

avatar image Rudy Q ♦♦ STAFF Apr 17 '17 at 06:26 PM

I wanted to check in and see if you had made any progress on preparing a stripped down version of the project so that I could take a closer look?

avatar image Gomo Apr 17 '17 at 07:40 PM

I wanted to do this today, but recently I've discovered some bug which causes my game to crash after opening video. Finally I narrowed it down to potential 4 files - so probably I'll fix it tonight but this debug build I'll have to make it later.

avatar image Gomo Apr 18 '17 at 07:39 PM

I found asset causing new crash - it turns out that between older version and new version there were no differences (at least according to diff tool) - so another crazy bug in my project. Also just finished stripping debug project from unnecessary files - and unfortunately crashing widget works just fine - I'm starting from the beginning...

avatar image Gomo Apr 18 '17 at 08:04 PM

OK, now my project reports several compilation error (no changes from yesterday when everything worked fine) - i'ts like compilation errors from debug project was infecting original project. Is there some shared cache based on names, which could screw this up?

avatar image Gomo Apr 19 '17 at 06:11 AM

Finally reinstalling engine worked. I turns out whatever I did, it damaged all projects. Today I'll try to make Debuging project again.

avatar image Gomo Apr 19 '17 at 07:40 PM

I've sent you a PM on the forum.

avatar image Rudy Q ♦♦ STAFF Apr 20 '17 at 03:31 PM

I took a look at the project provided. I followed the steps provided in the message on the forums. However, I was unable to get the project to crash. Could you test the zipped down version of the project provided so insure that the steps provided still cause the crash to happen?

avatar image Gomo Apr 20 '17 at 06:48 PM

I unzipped the file - reproduced the steps and crashed. So I suppose it is something wrong with my system - I'll try tomorrow at work. Beside that, any ideas?

avatar image Rudy Q ♦♦ STAFF Apr 20 '17 at 07:04 PM

Could you try verifying your engine?

Example:

alt text

avatar image Gomo Apr 20 '17 at 07:19 PM

Verified - no warnings. Maybe plugins? Physx (I have various Nvidia builds installed and also experiencing crashes when using apex in 3ds max)?

avatar image Gomo Apr 21 '17 at 11:19 AM

At work I have no crashes - so it seams it is something wrong with my home computer/system.

avatar image Rudy Q ♦♦ STAFF Apr 25 '17 at 03:21 PM

Additional questions:

  1. Could you provide your dxdiag so that I could take a closer look?

  2. Have you recently updated to the windows 10 creators update?

avatar image Gomo Apr 26 '17 at 06:28 AM

1.DxDiag in attachment. 2. I'm not sure - some updates I just confirm and forget, and I saw some update like this (similar name) but on other computer I am working on.

link text

dxdiag.txt (78.0 kB)
avatar image Rudy Q ♦♦ STAFF May 04 '17 at 08:33 PM

I have run a few more tests on our end and I have taken a look at the DxDiag that was given, however I have not been able to reproduce issue on our end.

Additional questions:

  1. Are you still experiencing this crash?

  2. Does this crash occur in the 4.16 preview?

  3. Have you been able to narrow down the cause further?

avatar image Gomo May 04 '17 at 10:33 PM

I'll check in a couple of days.

avatar image Gomo May 06 '17 at 12:38 AM

Crash is still there - in 4.15.2 and 4.16 preview. I've found that deleting two nodes in my Character blueprint also causes the same effect (also they are causing errors when I try to use nativization). My colleague advised me to delete cache from .../AppData\Local\UnrealEngine\4.15 which resolved many problems at work, but not for me, unfortunately. Just realized that I should update graphic drivers - so after that I'll try again.

avatar image Gomo May 06 '17 at 01:20 AM

Still crashing after drivers update.

avatar image Gomo May 08 '17 at 06:17 PM

Is there something more I can do? Like build 4.15.2 in debug? After updating to 4.15.2 I've found new bug crashing editor - narrowed down to render to canvas (not reproductible in blank project, doesn't appear on 4.16) so I am stuck with all this crashes.

avatar image Rudy Q ♦♦ STAFF May 12 '17 at 03:41 PM

Additional suggestions:

If you migrate your assets to a clean project does this crash still occur?

Could you try the "Refresh Nodes" options on the widget causing the crash?

avatar image Gomo May 12 '17 at 09:26 PM

If I use "Refresh nodes" Editor crashes. In my project - on startup, but in migrated content based copy-project - it didn't crashed on startup but when I pressed "restore closed windows" (or similar - don't remember exact command) then it crashed. I tried that again - Editor loaded, no option to bring back closed windows, so I tried to open blueprint manualy - and then it crashed. So basically it crashes always on opening this blueprint (even after refresh nodes).

avatar image Gomo May 12 '17 at 10:21 PM

It crashes even when I try to bring context menu over this blueprint.

avatar image Rudy Q ♦♦ STAFF May 17 '17 at 05:01 PM

Could you provide the complete callstack from the crash reporter window (including machine ID)?

avatar image Gomo May 17 '17 at 09:13 PM
avatar image Rudy Q ♦♦ STAFF May 23 '17 at 07:45 PM

Could you try using the fix up redirectors feature?

avatar image Gomo May 24 '17 at 10:58 PM

I had only 2 redirectors - but fixing them didn't help. Also I've updated today to 4.15.3 - but it is still crashing

avatar image Rudy Q ♦♦ STAFF Jun 06 '17 at 07:57 PM

I just wanted to clarify that you were not seeing the crash in the latest 4.16 (4.16.1 as of post (06/06/17))?

avatar image Gomo Jun 07 '17 at 02:01 AM

Bug still present in 4.16.1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Gomo,

After extensive testing, we have been unable to reproduce this issue on our end. Without a reproducible test case we are unable to move forward. I will be marking this post as resolved for tracking purposes. However, if at anytime you are able to provide a reproducible test case please feel free to reopen this issue and I will be happy to take look.

Thanks,

more ▼

answered Jul 24 '17 at 07:45 PM

avatar image

Rudy Q ♦♦ STAFF
46.8k 542 125 506

avatar image Gomo Jul 24 '17 at 09:20 PM

I've fixed this bug by recreating this widget. After that Some other widget was still crashing, but for some time it doesn't do that anymore. For now everything is working

avatar image Rudy Q ♦♦ STAFF Jul 24 '17 at 09:25 PM

I am happy to hear that you were able to workaround your issue. As stated above it the issue returns and you have more information on how to reproduce this issue please feel free to reopen the thread with more information.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question