x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How do I make landscape shadows look good with a Stationary light?

Here's my setup:

  • Outdoor scene with the default Landscape resolution.

  • I have a Stationary directional light for the sun, and a Static sky light.

  • I have a lot of foliage that doesn't cast a static shadow (worried about overhead, plus the foliage animates with WPO so I don't think baked shadows would look good).

  • Because of the foliage, I need some dynamic shadowing, so I cranked up Dynamic Shadow Distance on my stationary sun light to 2000.

Turning up Dynamic Shadow Distance works great for small objects, but it seems to artifact badly on landscapes. Here's a before/after:

no dynamic shadow (no dynamic shadow)

dynamic shadow distance turned up (dynamic shadow distance turned up)

I've played with a lot of dynamic shadow settings and can't seem to avoid this issue -- dynamic shadows make the landscape quads stand out very noticeably.

I could turn off dynamic shadowing on the landscape, that causes all of its baked self-shadows to disappear when inside the Dynamic Shadow Distance, resulting in no self-shadows at all.

In short: how can I get nice crispy dynamic shadows on close-up actors without creating artifacts on my landscape?

Product Version: UE 4.15
Tags:
more ▼

asked Apr 11 '17 at 10:57 PM in Rendering

avatar image

rinbu
107 2 5 12

avatar image MikeyBGames Mar 13 '18 at 03:46 AM

I'm having this same issue, Did you find a solution? Please could you share it if you did. thanks!

avatar image rinbu Mar 13 '18 at 04:36 AM

Unfortunately it seems there's no silver bullet answer -- this sort of artifact seems to be part and parcel with modern dynamic shadow techniques. I think you'll find if you crank your Shadow Bias (on your stationary light) way up, it helps significantly (note the slider only goes up to 1 but you can type in higher values). However that tends to make objects look like they're floating, which you can somewhat offset by turning on Contact Shadows. Tweaking dynamic shadow quality is a bit of a tightrope act.

I have noticed that really large objects tend to suffer the most, so I'd recommend making sure your world/landscape scale is reasonable (using a human scale reference).

Sorry I don't have a more satisfying answer, good luck!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question