x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Error packing project - Directory NotFoundException

So I'm trying to package a demo of my game. I duplicated my project, changed the name by appending DEMO after and made the necessary adjustments to my content so the demo only includes one level. Everything works fine until it comes time to package the project. The packaging ends with "Uknown Error" and when I look at the output log and show only messages and then filter for the word error I get the following messages:

 MapCheck: Info Map check complete: 0 Error(s), 0 Warning(s), took 89.743ms to complete.
 LogTemp:Display: IPP ERROR: Application exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\PeterComp\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles'.
 LogTemp:Display:    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
 UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: System.ArgumentException: An item with the same key has already been added.
 ble`1 Distribution, Nullable`1 Prebuilt, Nullable`1 RunTimeoutSeconds, String SpecifiedArchitecture, Nullable`1 IterativeDeploy, Nullable`1 FastCook, Nullable`1 IgnoreCookErrors, Nullable`1 RunAssetNativization, Nullable`1 CodeSign, Nullable`1 TreatNonShippingBinariesAsDebugFiles, String Provision, String Certificate, ParamList`1 InMapsToRebuildLightMaps, Pa
 UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

The weird this is that the first error "DirectoryNotFoundException" is mentioning something to do with Apple and MobileDevice but I'm packaging for Windows X64.

Also there's the message "An item with the same key has already been added". I thought this was referring to the ProjectID that is generated but I've generated several new ones and nothing helps.

Product Version: Not Selected
Tags:
more ▼

asked Apr 12 '17 at 06:33 AM in Packaging & Deployment

avatar image

TorQueMoD
1.2k 82 112 145

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Oh, I finally got it working. I deleted the Intermediate and Saved folders in my project directory and it packaged fine after that. Very strange but hey, it works so I'm happy.

more ▼

answered Apr 12 '17 at 07:47 AM

avatar image

TorQueMoD
1.2k 82 112 145

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The same for me it solved the problem

more ▼

answered May 15 '18 at 02:03 PM

avatar image

oneforall
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question