x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Think it's a problem with the Event Play and Event Ticks

Ok, so I have no idea what's going on. I'm not getting any errors when I hit play yet nothing moves. I have seven planets that rotate around a sun, and a flying pawn I made myself. When I hit play, the planets aren't moving and my pawn only moves back and forth???? It doesn't roll or pitch or yaw, it just moves back and forth while the rest of the level seems to be frozen. It happens in every single map and I haven't changed anything since last night, when it was working perfectly fine, except created some materials.

Please help, I know its kind of vague but I'm new to this and this error just doesn't make any sense to me. I have no clue where it could be based. I've tried restating Unreal and my computer, but it's still the same.

https://i.gyazo.com/01d14c6bc9589b58e551e37da2461907.png the level

https://i.gyazo.com/2657657131f1bd230f8b00d0dace0e6a.png these are the planet's blueprints for the rotation

https://i.gyazo.com/5365c3b4ab0589aa072dce1546255608.png how the pitch works (its the same for yaw and roll)

https://i.gyazo.com/3246e6dd5a1f5ba93889c6d3d8f57573.png and literally the only thing that still works, moving forward and backwards

Product Version: UE 4.15
Tags:
more ▼

asked Apr 16 '17 at 04:26 PM in Using UE4

avatar image

Keop1
3 1 2

avatar image neelix32 Apr 16 '17 at 05:35 PM

Do you have physics enabled on your pawn? Also, do you have any movement components in your blueprints (for example floating pawn movement)?

avatar image Keop1 Apr 16 '17 at 05:40 PM

My pawn does have physics enabled. I'm not sure what you mean by the movement components

avatar image neelix32 Apr 16 '17 at 05:43 PM

Try disabling the physics simulation and see if that fixes the left and right movement. By movement components I mean one of these:

alt text

avatar image Keop1 Apr 16 '17 at 05:48 PM

nope, don't have any. Disabling physics actually gives me errors because then Impulse doesn't work.

avatar image Keop1 Apr 16 '17 at 05:43 PM

I don't see anything that says "movement" at least, also when I hit "simulate" I don't see the arrow (thingies? not sure what they are) flowing through the blueprints

avatar image Keop1 Apr 16 '17 at 06:57 PM

welp, I might just cry myself to sleep then :'(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Oh, I fixed it by creating a new game mode and replacing it in all levels. I don't know why it works but it does.

more ▼

answered Apr 17 '17 at 12:42 AM

avatar image

Keop1
3 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question