x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Game crashes, Splash Screen to Black to Crash

I originally ran into this problem when I was still running in 4.14. Essentially, I launch my project to my iOS iPhone 6+, it successfully deploys, I launch it from the app icon, it loads, the splash screen appears, it turns to a black screen, and then the app exits to the homesceen/menu.

I'm not really sure when this started, I had a wedding and moving to deal with but somewhere in the middle, my game no longer was playable on my iPhone. I've been able to successfully deploy via launch the past year till now. After failing to discover a fix for this problem, I tried the same project in 4.15.

However, the problem still remained. I've googled up and down the web with out much success. I've died deleting my saved and intermediate folders. Hoping I can resolve this soon, any help would be greatly appreciated. I've attachment my deployment log for anyone to look at. If there is someway to obtain a crash report from the device, I'm all ears.

Thanks

Deployment log

Product Version: UE 4.15
Tags:
deploymentlog.txt (431.8 kB)
more ▼

asked Apr 17 '17 at 09:36 AM in Packaging & Deployment

avatar image

sarchasm
81 16 19 25

avatar image sarchasm Apr 17 '17 at 10:04 PM

Found some errors when it does crash. Investigating now. Perhaps just a coincidence.

LogHttp:Warning: 000001A820EF3100: request failed, libcurl error: 6 (Couldn't resolve host name) LogHttp:Warning: 000001A820EF3100: libcurl info message cache 0 (Connection 2 seems to be dead!) LogHttp:Warning: 000001A820EF3100: libcurl info message cache 1 (Closing connection 2) LogHttp:Warning: 000001A820EF3100: libcurl info message cache 2 (TLSv1.2 (OUT), TLS alert, Client hello (1):) LogHttp:Warning: 000001A820EF3100: libcurl info message cache 3 (Could not resolve host: datarouter.ol.epicgames.com) LogHttp:Warning: 000001A820EF3100: libcurl info message cache 4 (Closing connection 3)

avatar image sarchasm Apr 17 '17 at 11:34 PM

Got the iOS logs. Hard to parse them... but investigating..

iOS logs

backspin.log (26.9 kB)
avatar image sarchasm Apr 18 '17 at 12:56 AM

I was able to deploy it via iTunes. Once I launched it and after the splash screen, it remained black indefinitely. Not sure if that means anything.

avatar image Steve Hardister ♦♦ STAFF Apr 18 '17 at 03:20 PM

Hi sarchasm,

We need some more information in order to help troubleshoot this issue...

  • Are you able to reproduce this with a blank project?

  • With the Project in question, do you have the main (opening) map set to default in your Project Settings?

  • Have you built your lighting/lightmass before packaging and are you using a light importance volume ?

  • What is the exact device they you are using and what version of iOS is on that device?

  • Please try packaging again with this project and provide the complete Output log.

  • Also, supply the log from the crash from the device if possible:

Crash log from Device:

  • Connect device to a Mac

  • Open XCode > Window > Devices

  • Select your device

  • Select 'View Device Logs'

  • Select the process which matches your Game and Crash date/time

  • Right-click on the process and select 'Export Log'

Supply all, or as many of the above as possible.

Thank you,

Steve H.

avatar image sarchasm Apr 18 '17 at 05:28 PM

Thank you so much for your response.

Without much evidence, I was convinced its because on the road I absently minded updated my iPhone 6+'s iOS. My investigation through the Answer Hub has shown me that this seems to happen off and on when perhaps the current version of UE4 doesn't support the latest iOS. However, due to Apple's update policies I have no way of testing that because its too late for me to rollback my phone to the previous verison. Just for clarification, launching to my device has worked over the last year and just stopped running properly within the last month while I've been moving.

To your points.

1) EDIT: After I originally posted this, I spent 30 minutes making a new project and deployed it successfully. So it must be something with my project, I just don't know what. This makes me happy and sad... grr.

2) I do have the default map settings set in my Project Settings.

3) I have built lighting and a I do have a light importance volume in my default level.

4) I am using an iPhone 6+, it has at the latest iOS (10.3.1)

5) When you say package, does it matter if I'm packaging the entire project or if I'm launching/packaging just the level? I've been doing mostly the latter. OutputLog.txt

6) I'm using a PC to do all this, do I need a mac? I thought I added the crash logs from the device in one of my above comments, but I'll add new ones here. I used these steps https://wiki.unrealengine.com/Mobile_Development_Troubleshooting_Guide#How_to_get_logs_off_of_an_iOS_device

CrashLog.log

EDIT: Just for kicks, I copied the Content folder from my real project to the Test and... other than all the mismatch errors of my blueprints, it still runs. So I think I can rule out the blueprints...

outputlog.txt (493.6 kB)
backspin.log (27.0 kB)
avatar image Steve Hardister ♦♦ STAFF Apr 18 '17 at 07:07 PM

You do not need a Mac to deploy to your device if your project is Blueprints only. If you have code in your project you will need to remote build on the Mac in order to convert code in Xcode.

avatar image Steve Hardister ♦♦ STAFF Apr 18 '17 at 07:01 PM

I see the following warnings in your log:

 WARNING: No Visual C++ installation was found. Please download and install Visual Studio 2015 with C++ components.
 LogPlayLevel: CommandEnvironment.SetupBuildEnvironment: WARNING: Couldn't find installation of Visual Studio
 LogPlayLevel: CommandEnvironment.SetupBuildEnvironment: WARNING: Assuming no solution compilation capability.

You can correct the first issue by opening Visual Studio and choosing to install Visual C++ -You do not need to reinstall VS. ,If Visual Studio is already installed, choose File | New | Project | C++ and you will be prompted to install the necessary components.

avatar image sarchasm Apr 18 '17 at 07:10 PM

Odd, I am using a blueprints only project. I haven't dealt with Visual Studio since starting this project. Is there something I could have done that would cause it to think that?

In fact, I don't even have Visual Studio on this PC.

avatar image sarchasm Apr 18 '17 at 08:26 PM

I've been able to copy and paste parts of my blueprints and other files from my project to the new test project I created to test the launching/device. It still seems to be working but obviously all my blueprints, settings, etc are all a mess, but they still run. Which I guess is promising.

When I posted this topic, it would launch, then show a splash screen, go to black, and then crash/collapse. After fooling around with it all day yesterday, I was able to prevent it from crashing, so it just hangs on black now. When that happened I made a new post. I should have probably closed this one and redirected to that one here, https://answers.unrealengine.com/questions/589994/launching-to-ios-splash-screen-then-constant-black.html

My apologies. Thomas just asked me for a copy of my project files which I sent him.

avatar image Steve Hardister ♦♦ STAFF Apr 18 '17 at 08:59 PM

Ok, Since Thomas has requested you project files, he'll be able to examine this more closely so I'm closing this post down.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Apr 18 '17 at 08:59 PM by Steve Hardister for the following reason:

Duplicate Question


0 answers: sort voted first

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question