x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Buffer Visualization for Custom Depth not working

I am trying to use the custom depth pass to draw outlines on specific objects. The PP material works fine on a new blank Project, but on these two specific Projects, it just won't render any of the marked actors in the custom depth pass. This person seems to have had a similar issue: https://answers.unrealengine.com/questions/362828/buffer-visualization-custom-depth-not-working.html

I have tried going to the Rendering options and enabling the "Custom Depth-Stencil Pass" in the Project Settings (which was off) but that sadly didn't fix the problem. Does anyone have an Idea about what might cause this behavior? The image below might explain the problem:

alt text

Thanks in advance.

Product Version: UE Github Master branch
Tags:
ihavenodepth.png (159.5 kB)
more ▼

asked Apr 17 '17 at 11:44 PM in Using UE4

avatar image

Chisi
6 1 1 2

avatar image danlev Apr 22 '17 at 04:10 AM

I'm having this same issue. No clue what's causing it.

avatar image VKleinMP Apr 28 '17 at 05:30 PM

I'm having the same problem. The custom Depth Buffer simply don't work at all. material and project settings work fine in an older project, but not in my actual project. Error first encountered in 4.15. A working 4.14 project converted over into 4.15 works.

avatar image Andrei Simion Jun 27 '17 at 07:07 PM

I had the same problem, none of the buffer visualization worked. My solution was to check Show -> Post Processing -> Post Process Material inside the editor. I previously unchecked them because I didn't want the blur and other post process effects enabled.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question