x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launching to iOS, splash screen then constant black screen

I previously posted about an issue where I would launch my game from the editor to my iPhone, it would display the splash screen, go black, and then exit to the iPhone main screen/menu.

I've tried a lot of different suggestions on these boards, but I haven't really made any progress. It's driving me crazy. I just set my phone back to factory defaults and then restore it.

Now, my game is forever hanging in blackness after the splash screen. The app isn't actually crashing like it was prior, in fact if I double tap the home button I can definitely see it continuing to run.

Any suggestions would greatly be appreciated.

Product Version: UE 4.15
Tags:
more ▼

asked Apr 18 '17 at 02:24 AM in Packaging & Deployment

avatar image

sarchasm
81 16 19 25

avatar image Thomas G ♦♦ STAFF Apr 18 '17 at 08:00 PM

Hello Sarchasm,

I was unable to reproduce this issue. To investigate this issue further, having a copy of your project where the issue occurs would help in my investigation. You can privately message me on the forums here: https://forums.unrealengine.com/private.php?do=newpm&u=680446

Thanks!

avatar image sarchasm Apr 18 '17 at 08:28 PM

HI Thomas,

I sent you a private link of my 4.15 project.

I should have probably closed it, but I had posted an earlier thread when the symptoms changed from crashing to the constant black. You can see some of the steps that Steve and I were going over here; https://answers.unrealengine.com/questions/589660/game-crashes-splash-screen-to-black-to-crash.html

Thanks again.

avatar image Thomas G ♦♦ STAFF Apr 19 '17 at 01:32 PM

I was able to get your project to run as expected while testing on my iPhone 5 s. To do this I deleted the Saved and Intermediate folders in your project then launched the project onto the device. Let me know if this does not work for you!

What iOS device specifically are you trying to launch to?

avatar image sarchasm Apr 19 '17 at 07:24 PM

Thanks for looking at it.

Yeah, I tried that a few times to no avail and just tried it again. I am trying to push from a Windows 10 PC to an iPhone 6+ running 10.3.1. In the other thread, I was able to create a new project with new provisions/certificates and launch that to my phone however. So its clearly something with my project and not the phone, its just not causing any errors or something.

avatar image sarchasm Apr 19 '17 at 08:38 PM

I think I got it mostly working. There must be some project settings that I can't quite pin down that are causing the problem, some settings that are brought over between version changes, etc.

Essentially, what I ended up doing was making a brand new project, pasting my content folder over the new project's content folder, and then manually exported the pertinent projected settings from my project (inside the editor) to the new project, mostly collision, input, and maps and modes.

(It would be super helpful if when you clicked "All Settings" in the project settings that you could export all the settings, instead of just exporting the description of the project.)

Still missing some settings, hoping will be easy to find them.

avatar image schubboy Jun 16 '17 at 06:55 PM

Thomas, seeing that you are staff, I figured I'd add my experience with this as well. Mobile MSAA seems to be causing the crash on iPad Air 2, but not an older iPad Air, and iPhone 7 Plus is fine too. Disabling Mobile MSAA in the Rendering settings section fixed the crashing issue. Its a workaround for now, but certainly a bug.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After getting my project all cleaned up and ready to go, submitted to my source control, I tested a few things to see if I could find out what the file in question was.

Probably could have guessed this, but it wasn't really obvious till now... but culprit was my DefaultDeviceProfiles.ini. When I copied that to my new project that was launching properly to iOS, it all of a sudden failed. Delete it and it launches successfully again. The more you know...

DefaultDeviceProfiles

Edit: In fact, I think I found the real cause. I had deleted my DefaultDeviceProfiles.ini and planned to rebuild it. But while I was in the process of taking stock of my project and some of the new features of 4.15 I haven't yet explored, I may have stumbled upon the real reason.

When I went to the Project Settings - Rendering, I changed Mobile MSAA to 2x MSAA and it caused the same exact issue I was experiencing earlier. Changing it back to No MSAA and everything works again. I don't know if its my iPhone 6+ exclusively or not, but it does not seem to like MSAA and causes a lot of issues. Possible bug?

more ▼

answered Apr 19 '17 at 09:16 PM

avatar image

sarchasm
81 16 19 25

avatar image schubboy Jun 16 '17 at 06:52 PM

Your answer solved my problem as well. It seems that MSAA works fine on iPhone 7 Plus, older iPad Air, but not newer iPad Air 2 (makes no sense). But turning off Mobile MSAA solved the problem for me. No more crashing after the load screen.

avatar image sarchasm Jun 16 '17 at 07:51 PM

Glad it was of help to someone! Just hope Epic sees this eventually and fixes it!

avatar image CGsquirrel Dec 01 '17 at 09:02 PM

Hi Guys,

I'm having the same problem. After the splashscreen the app goes back to the ipad homepage.

Where can I find the DefaultDeviceProfiles.ini?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question