x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Draw Material to Render Target not working when packaged

I found an older question about the render target working when playing in editor but not on standalone/packaged.

I have similar problem, but using event tick instead of event begin play. The render target works fine when PIE but not when packaged (can't test standalone because I'm using VR). The delay mentioned in the other topic made no difference (well, I'm not drawing anything at BeginPlay so that's no surprise). Everything else seems to work perfectly in the packaged project, I'm just not able to draw to the render target. Is this a known bug or should I try to find some other error in my blueprints? I guess I'm a little bit out of luck since it's for an art project and the premiere is tomorrow... Just have to play it in editor.

What I want to achieve is that the viewer "paints" the world around themself by looking around. Like I said, it's working perfectly on the VR preview but not on my packaged project. Any help will be appreciated!

Here are the screenshots from my blueprint (used the Draw Material to Render Target livestream as a tutorial for this): alt text

alt text

Product Version: UE 4.15
Tags:
more ▼

asked Apr 18 '17 at 02:48 PM in Blueprint Scripting

avatar image

rassari
21 3 3

avatar image Calibanul Jun 01 '17 at 04:31 PM

have the same problem as well :(

avatar image AndrewHurley Jun 05 '17 at 08:03 PM

Hey rassari or Calibanul,

Would you be able to share with me your project? As there might be other variables not accounted for when setting this up to test. I could not find anything regarding the issue at hand specifically reported internally.

Have you tried moving any of this out of the construction script and into an EventBegin Play configuration, just to see if it does work?

Thanks,

Andrew H.

avatar image KaranMonster Oct 14 '18 at 10:24 PM

@AndrewHurley , thank you so much! I was running into a similar issue where I was seeing certain textures from my BP not being rendered. I moved things over from Construction Script to EventBeginPlay and everything worked as expected.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Sorry, I'm hiking the Appalachian Trail at the moment so I'm unable to do that before the end of August! Thanks for your reply though!

more ▼

answered Jun 05 '17 at 10:01 PM

avatar image

rassari
21 3 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question