x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Packaging failed :unknown Error

having trouble to package android game i recently update my android codework to 1R6 and i start getting this problem

plus i dont know why it keeps running to my other unrelated folders when i tried to package my game

i my settings and error logs here , please help thankyou

Product Version: UE 4.15
Tags:
more ▼

asked Apr 18 '17 at 03:39 PM in Packaging & Deployment

avatar image

yuukyun
0 2 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey.

First thing - when you change something crutial in Java - delete the E:\Project\UNreal\RisekingdomProject\Intermediate\Android\ directory. Unreal has nasty problems with cacheing and sometimes You have to clear the cache yourself. I'm usually do it every build, just in case.

Second - always use the recommended codeworks, unless You are really good in modifying the engine and in Android overall :) You are using 1r5 now - so good.

Third - download all of the extras from Android SDK Manager. It doesn't weight much, but for instance - I can see You doesn't have Google Play Services downloaded which might be an issue.

Now, from the log I can see that there is an issue with extracting google play services from AAR:

Error: E:\Project\UNreal\RisekingdomProject\Intermediate\Android\APK\JavaLibs\play-services-ads-9.2.0 is not a valid project (AndroidManifest.xml not found).

Most of the JavaLibs are the directories extracted from AAR files located somewhere here:

E:\Apps\EpicGames\AndroidCode_Works\NVPACK\android-sdk-windows\extras\android\m2repository ....\Engine\Source\ThirdParty\Android\extras\google\m2repository ....\Engine\Source\ThirdParty\Android\extras\android\m2repository

This is why I recommend getting all of the extras from SDK Manager ;)

more ▼

answered Apr 26 '17 at 08:37 AM

avatar image

zompi2
650 24 47 145

avatar image yuukyun Apr 26 '17 at 02:37 PM

Thanks , i fixed it now , it can package my game to apk

i have some question , if i want to repackage my game , do i need to clear that cache again ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Check again your path you entered in the first picture

Or delete all android tools and reinstall it, maybe The update to Version 1R6 has modified or deleted some files

more ▼

answered Apr 18 '17 at 04:55 PM

avatar image

TJ1999
43 3 4 8

avatar image yuukyun Apr 19 '17 at 02:46 AM

i reinstall my codework (to 1r6 again ) and change the directory path , but it still give me the same problem

avatar image TJ1999 Apr 19 '17 at 06:39 AM

Have you set up the Android settings section in project settings?

avatar image yuukyun Apr 19 '17 at 07:53 AM

yes i have , and the error msg is actually the same like the one before reinstallation

avatar image Matthew J Apr 21 '17 at 07:21 PM

Hello yuukyun,

When you reinstalled the SDK, did you restart your computer between uninstalling and reinstalling the SDK? This can help ensure that all of the original installation is gone. Also, are you installing the SDK provided with the editor or one downloaded online?

avatar image yuukyun Apr 22 '17 at 12:37 AM

yes, I restart when i uninstall and installing my sdk , i install it from androidcodeworks's sdk manager

avatar image Matthew J Apr 24 '17 at 07:27 PM

Can you show a screenshot of exactly what you're installing through the SDK manager? Please try installing through the suggested method in our documentation, by installing the CodeWorksforAndroid-1R5-windows.exe located in your engine installation at Epic Games\4.15\Engine\Extras\AndroidWorks\Win64

avatar image yuukyun Apr 26 '17 at 06:35 AM

i reinstall my android codeworks back to 1r5 using installer from \4.15\Engine\Extras\AndroidWorks\Win64

but it still give me probably same error again , here some screenshot from my settings and sdk manager + packaging error log

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question