x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint Viewport Empty

Hi !

I just came across a very annoying bug and I have no idea what to do now.

Some of my Blueprints have an empty viewport after reopening them. As you can see in the screenshot, there are components in the blueprint and i have already worked with them and moved them around in the viewport, but after reopening the blueprint, the viewport is empty. I already tried moving and adding components but nothing happens. It's like there is nothing in the blueprint. Only a few of my Blueprints are affected. I recreated this blueprint 3 times already, and it keeps happening.

I feel like it has to do with the RotatingMovement Component, since only blueprints that have this or the "Interpolate To" component are affected by this bug. It's really annoying, i don't want to recreate the blueprint again.

Is really the RotatingMovement component the problem or can this be caused by something else ?

Thank You !

alt text

Product Version: UE 4.12
Tags:
ue4error.png (540.6 kB)
more ▼

asked Apr 18 '17 at 11:03 PM in Bug Reports

avatar image

snair_
32 5 5 6

avatar image Thomas G ♦♦ STAFF Apr 19 '17 at 03:00 PM

Hello SnairFX,

I was unable to reproduce your issue on our end. I have a couple of questions that will help me narrow down the issue you are experiencing.

  1. Can you reproduce this issue in a new project?

  2. If so could you provide a detailed list of steps so I can reproduce your issue on our end?

  3. Could you provide a screenshot of your event graph for a blueprint with your issue?

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello !

I tried to reproduce the issue in a new project and came across a solution.

Whenever I have the destroy actor node in the front, the viewport will become empty after pressing simulate. The only thing that brings back my components inside the viewport is, if I remove the destroy actor node and put it at the end of my blueprint, then recompile.

This is weird, since this is the first time I'm having this problem, but not the first time I used the destroy actor node in front of my blueprint.

After changing this in my original project, everything is working fine!

Thank you for the fast answer!!

alt text

alt text

alt text

more ▼

answered Apr 20 '17 at 09:20 AM

avatar image

snair_
32 5 5 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question