x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashing on load

hey there. I've been working on my project all day without a hitch. I started a build and the build crashed. This was a shock because it has not happened to me yet, so I closed everything and now i can no longer start my project. The editor gets to roughly 93% loading and crashes out with basically zero information in the log and crash window.

I don't know what to do and I really don't want to revert a whole day of work. What I don't get is that the project was working without a hitch when hitting the play button in the editor. It was the packaging process that caused me to notice that something was up.

Is there anything that can be done to read the dmp file? It's gibberish for me. I tried the usual steps of deleting the intermediate and saved folders, but with no luck.

I hope you can help! thanks alt text

Product Version: UE 4.15
Tags:
134859-capture.png (19.4 kB)
more ▼

asked Apr 20 '17 at 02:39 AM in Everything Else

avatar image

Floggins
70 6 8 11

avatar image Adnoh Apr 20 '17 at 11:39 AM

whats your project type? c++ or BP only?

I now it sucks - but duplicate your project folder, delete your startup map and check if your editor comes back up. search for level build datas and remove that (it happens a lot to me that this is the cause). only do that all in your duplicated folder of course so you don't lose anything :)

avatar image Floggins Apr 20 '17 at 12:17 PM

I've actually made a little progress. I removed the startup map from DefaulyEngine.ini and got back into the project. The crazy thing I have happening now is that I can't load that map in the editor... BUT I can run the game, which loads that map. :( But I think I've narrowed down which blueprint is causing my crash. Even though it's not in that map (but does get spawned from within it), it's the only bp that I'm not able to open right now.

and it's a BP-only project btw.

I'll post back here if I find a solution,, but my guess is that there's a dependency issue going on.

avatar image Adnoh Apr 20 '17 at 12:20 PM

ok. sounds good. have you looged in the log? something is always written even if it crashes.

try adding a c++ class, so you have a c++ project. then open the project in visualstudio (from file menue in editor). close editor, and RUN the project WITH DEBUGGER attached from visual studio - you now have the power of a attached debugger :) you see exceptions, can set breakpoints and can narrrow down the problem.

avatar image Floggins Apr 20 '17 at 01:57 PM

yeah, the log stops at a point that's unclear. It seems to be looking for a bp in the game folder that doesn't exist, So it seems to be trying to access data that has not been built yet. I'm not sure how that's possible, so I don't think that's the actual problem. I think it's whatever that bp is compiling is throwing out an error. I did see a new error in the output log though, so I'll have to solve that before getting further. What I don't get is if i run the game from the my title screen map in the editor, it all works great. It has no problem loading the map that's causing the crash.

I'm definitely going to try your idea of running via visual studio. hopefully I'll get the missing piece of info.

Thanks for the replies so far!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

so it turns out that I has a corrupt texture that was causing a kernel panic on build only. I removed it and a bunch of others (i was not using it nor the others but for some reason they were being built anyway) and now everything works like a charm. It took a while, but it for forced me to finally clean up some warnings I had been having for a while now. Now I have full play loops with zero errors and zero warnings.

Thanks for the replies Adnoh, it was much appreciated!

more ▼

answered Apr 21 '17 at 11:59 AM

avatar image

Floggins
70 6 8 11

avatar image Adnoh Apr 21 '17 at 03:13 PM

great to hear your back on the road :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question