x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Engine crashes upon completion of lighting build

Hi, I am using a version of UE4 compiled from visual studio to allow dedicated server creation. Everything has been working correctly but now whenever I build lighting, the engine crashes when the lighting build finishes with the following error: https://pastebin.com/xsK8xr9Z

What changed between my last successful lighting build and the current project is, to my memory:

  • I added a sky map, removing it does nothing

  • I changed a lot of objects in the map to static mobility instead of movable

  • I added an LOD to one mesh

  • I added a lightmass importance volume (Large size) (Tested, changing the size or removing this does not fix the issue)

  • I added 6 large static meshes to cover the entire map's edges to prevent people from exiting the area

  • I now have a total static mesh count of something like 10000 total on the map

Building on any other map in the project works fine. I have tried changing some of the things and following other solutions to this issue, but nothing has worked. Considering building lighting takes around 20 minutes each time, I haven't had to the time to try everything yet. Note: I am running on a computer with 16 GB of RAM with a 100GB pagefile and have tried updating drivers to no avail. Changing the lighting quality also does not help.

  • Edits:

  • Formatting

  • Rebuilt light-mass, the engine, and the project to no avail

  • Checked antivirus logs, no errors

  • My windows x64 username does not contain and non US standard letters

  • I have updated my drivers for my graphics and everything else

  • I am going to try removing large chunks of the map until a build works successfully to pinpoint the issue

  • It appears that the crash occurs when importing at 14% completion when it does crash

  • I have discovered that the issue is certain objects in my scene.

  • I have spent hours trying to pinpoint the issue but am unable to as it appears there are multiple objects in my scene causing this crash

  • Cutting all of the actors in the scene and then pasting them fixes all lighting issues, but it resets any customized instances of blueprints which basically ruins my entire road system and also rotates a lot of buildings. Id like to avoid this if possible.

Product Version: UE 4.15
Tags:
more ▼

asked Apr 20 '17 at 04:30 AM in Bug Reports

avatar image

Littork
1 2 4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I cut and pasted all of the actors in my map, then rebuilt my entire road system which it broke using better practices. This fixed any crashes.

more ▼

answered Apr 23 '17 at 11:56 PM

avatar image

Littork
1 2 4

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question