Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My character won't move

Good morning / afternoon / evening or night!

Quick question, but a very frustrating one. My character won't move. I'm using a First Person Template, and I can't move around with my character. I can look around all right, but the WASD key or the controller won't move my character. Here's the blueprint, attached as an image.

alt text

I've tried changing everything I can think of, but still to no avail. Has anything like this happened to anyone in the past? As far as I know, there's nothing wrong with the character... please help! :D

Product Version: UE 4.15
captura.jpg (188.4 kB)
more ▼

asked Apr 21 '17 at 10:32 AM in Using UE4

avatar image

21 3 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm not close to the Editor but maybe I can try to help, first of all "No sabia que el editor podia verse en otro idioma como Espanol" (I wasn't aware of the editor in other languages), this looks really weird to me, those false and true pins coming out of the get move forward and get move right, have you tried adding a const value to the character movement directly from the input event? my guess is that the calculation coming out of the move right and move forward is not working.

more ▼

answered Apr 21 '17 at 11:52 AM

avatar image

361 16 17 25

avatar image braisbr1 Apr 21 '17 at 12:25 PM

Hi Nullbot! Yes, the editor comes in other languages haha. I would rather have it in English, but I haven't put the time or effort into changing it!

In any case, those true and false pins are the default ones for a first person character template in Unreal, so they should work. I mean, they were working earlier. The problem first appeared when I tried moving the camera from its default position (I wanted it not to pivot around the mesh, but around itself). When I changed the camera position, the movement functionality stopped working.

I tried setting the camera back to its original position, but still to no avail. Everything as far as I'm aware is back to defaults, but no movement so far :(

avatar image virtual_nomak Apr 21 '17 at 12:36 PM

Hi Brais, ok so I can see that the camera component is inside of the mesh (by default this is attached to the root component) just reset that, and about the movement well the player moves around using the movement component, I cannot tell why the player might be static (I'd have to see your setup more closely) just try to fiddle with the movement component or try to open a new project using a 3rd person template and try to find the differences. I wish I could help you more but without the editor in front of me I feel handicapped ^^

avatar image braisbr1 Apr 21 '17 at 01:03 PM

Hi again! I tried doing what you mentioned, but still no luck. Thanks a lot for the answers though! I'll try fiddling with the character a little bit more, but it looks like a very strange behaviour to me.

My best guess is that while I was modifying some parameter, some setting changed automatically without me noticing and now I can't pinpoint it. I'll keep trying, but I really don't want to move the whole scene to a new project. I'd love to find out why this is happening.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Please check your project settings. alt text

way5.png (80.0 kB)
more ▼

answered Apr 21 '17 at 03:54 PM

avatar image

127 2 5 11

avatar image braisbr1 Apr 21 '17 at 04:00 PM

Hi Dexkz, thanks for your answer, but unfortunately that's something that I've already checked.

I've imported another character from a FPS template and it works without a problem. I'll try to export my non working character into another project and see if I have trouble over there as well. I'm pretty convinced that I might have encountered a bug though, so I'll try to file a bug report as soon as I can check the project on multiple machines.


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question