x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Issue with 3D Widgets not showing in some BP's and not others?

Hi, I've been having an issue with my project where I add a 3D widget to one Actor and it will show, but I add the same one to another actor and it won't. More specifically I have an AI which has a screen space 3D Widget above its head for a health bar which appears/disappears when the player approaches/leaves. However if I create a brand new BP Actor and add the same widget to it (Default details), place it in the world nothing shows. There's also an issue where if I set the said health bar to visible in the AI BP by default nothing is there. And yet when I add the same widget to my player character it shows? I've tried recreating the issue in a brand new project and had no issues?

There seems to be no continuity to the issue; which leads me to believe its some sort of bug, however I could be wrong. Any help would be greatly appreciated!

Product Version: UE 4.15
Tags:
more ▼

asked Apr 21 '17 at 10:48 AM in Bug Reports

avatar image

TheLoneJuanderer
10 1 2 5

avatar image Rudy Q ♦♦ STAFF Apr 21 '17 at 01:43 PM

Hello TheLoneJuanderer,

I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you take a look at your widgets "Space" setting for each widget (World space will show up in the blueprint Screen Space will not show up in the Blueprnit)?

  2. Could you make sure that your widget is not being clipped and that the draw size is large enough to fit the widget?

  3. Could you provide screen shots of any settings/blueprints/widgets that may be involved?

avatar image TheLoneJuanderer Apr 21 '17 at 03:40 PM

Hi Rudy thanks for the quick reply, I've since narrowed down the issue. This only seems to happen when an actor isn't spawned during gameplay.

e.g. I have an AI spawner which spawns enemies on begin play and once all of the first enemies are killed it spawns another wave. The first 'round' of enemies don't have the widget rendering, but the second do. This is the same with the player character because it is not in the level by default but dynamically spawned by the GameMode, but the widget appears.

Hope this new info will help us find the issue.

Thanks!

(I am unable to add screenshots for some reason)

Round 1 https://gyazo.com/19955d8cbd487f346f69e12da160a128

Round 2 https://gyazo.com/78044cf76c47c0993d403b684185540c

avatar image Rudy Q ♦♦ STAFF Apr 21 '17 at 06:08 PM

I am unable to reproduce this issue with the information provided. Could you provide screen shots of the actual widgets/blueprints/settings that are involved with this issue?

avatar image TheLoneJuanderer Apr 21 '17 at 08:47 PM

Here are the screenshots. I created a two brand new BP's in my project (TestBP1) (TestBP2). BP1 has the 3D widget and BP2 Spawns BP1 after 3 seconds. I dragged them both into the world. I forgot to mention that I am using them in screen space.

Thanks!

https://gyazo.com/69183667b43d66ea3dc8bba5df53fb2c

https://gyazo.com/ed8dddf20c077e61b5b9df12b74d9d24

https://gyazo.com/f93ca53f049cf1f373a2c016c13cfc06

https://gyazo.com/a611e6b6d89837b0d377d04452aed66f

https://gyazo.com/6dfd537982d6157afee2e2bddf38a7e7

https://gyazo.com/5bbb073043b07ca89e59265ceb2836f5

https://gyazo.com/c0c134f1f09ecd4ad1598cfd4b48ec3d

avatar image Rudy Q ♦♦ STAFF Apr 25 '17 at 05:09 PM

Could you provide a zipped down copy of the project that is having this issue so that I could take a closer look? If you would like to provide it privately, you could do so by providing a link via drop box for google drive in a private message to me on the forums.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello TheLoneJuanderer,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

more ▼

answered May 01 '17 at 03:57 PM

avatar image

Rudy Q ♦♦ STAFF
48.1k 542 125 507

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question