x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Find Sessions always returns 0 results [Advanced Sessions plugin with null and Steam]

After days of googling, reading and testing I still can't get this right. I am using the plugin Advanced Sessions. I am able to create sessions and play with or without LAN and with or without Steam, but I can't find the session on a different instance of the game.

I have tried with 2 PIE windows, 2 instances of packaged build on 1 machine and 2 different computers on LAN with same packaged build. Same result, the length of returned "Results" array from Find Sessions Advanced = 0.

Would be great if anyone have any pointers or a check list I can run down to fix it. :)

My DefaultEngine.ini : (When I test without Steam I simply turn "DefaultPlatformService=Steam" to "=Null".)

[/Script/Engine.GameEngine] !NetDriverDefinitions=ClearArray +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNet

[OnlineSubsystem] DefaultPlatformService=Steam PollingIntervalInMs=20

[OnlineSubsystemSteam] bEnabled=true SteamDevAppId=480 GameServerQueryPort=27015 bRelaunchInSteam=false GameVersion=1.0.0.0 bVACEnabled=1 bAllowP2PPacketRelay=true P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver] NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

My Game.Build.cs :

using UnrealBuildTool;

public class FreshFPS : ModuleRules { public FreshFPS(TargetInfo Target) { PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "OnlineSubsystem", "OnlineSubsystemNull", "OnlineSubsystemUtils" });

PrivateDependencyModuleNames.AddRange(new string[] { "OnlineSubsystem" });

PrivateDependencyModuleNames.Add("OnlineSubsystem");

} }

Product Version: UE 4.15
Tags:
more ▼

asked Apr 22 '17 at 02:58 PM in Blueprint Scripting

avatar image

SolidRubrical
5 1 3 6

avatar image Chumble May 22 '18 at 03:26 PM

Any chance you found a solution to this? I'm also having this issue. I would have thought that I would at least find all online sessions using appID 480 so running a Find Sessions Advanced should always return a few results but the array is always empty.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question