x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Navmesh won't build over a specific area ?

alt text

Hello everyone. This square in my Navmesh appeared for seemingly no reason today and I can't find how to get rid of it.

There's obviously no volumes blocking it here. Here's what I checked/tried:

-Moving the landscape moves the square with it (so it's probably tied to the landscape itself)

-Moving the NavmeshBoundsVolume doesn't change anything

-Deleting then Adding back squares of the Landscape doesn't make the bug dissapear.

-Deleting and creating a new NavmeshBoundsVolume doesn't change anything.

-Sculpting in the square without navmesh doesn't trigger any navigation rebuild.

-Making a copy of the Landscape, moving it and trying to build a new Navmesh also creates the same problem.

-Restarting UE4/PC as a last resort didn't work either.

-Working with the NavmeshRecast parameters didn't change the problem.

I'm now running out of options, I tried everything I could think of but nothing makes this damn square dissapear.

If anyone has an idea as to what's going wrong with my Navmesh I'd be more than happy to hear it !

EDIT: After further testing it seems that the Navmesh around the square is going bonkers when I use any terrain tool near it. Here's what happened when I used the Smooth tool near the outside of the square :

alt text

It pretty much removed the navmesh anywhere I used the smooth tool.

Product Version: UE 4.13
Tags:
more ▼

asked Apr 27 '17 at 04:00 AM in Bug Reports

avatar image

RomsIsMad
1 1 2 3

avatar image RomsIsMad Apr 26 '17 at 02:00 PM

Not long after this post I finally found a workaround but not what's causing the problem.

Here's what I did :

-Save my map's Heightmap on a png file

-Delete the old Landscape and Gizmo

-Create a new landscape with the heightmap and the same size parameters as the previous Landscape.

And this worked. In the end this is probably a bug, maybe the Landscape itself contained corrupted data ? I'm moving this post to the Bug Report section.

Here's the result anyways:

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey RomsIsMad,

After some investigation, I came across a similar issue that was marked as resolved in 4.16, but I'm not sure how related it is, as the description was fairly vague. Unfortunately, this issue cannot be made public due to it containing sensitive information.

I'd recommend upgrading a copy of the project to 4.16 Preview 1 just for testing purposes to see if it resolves the original issue if possible.

Otherwise, in order to investigate I'd need a way to reproduce the issue in a clean project on my end. Could you give this a shot in a clean project, and provide a detailed list of repro steps or a test project that showcases the issue so I can determine if I need to get a ticket in for this?

Thanks

more ▼

answered Apr 27 '17 at 01:30 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question