x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Sequencer: Render is brighter than in editor and Choppy

Hello all. So I've got my scene setup and a few shots. All of that is great. For reference, I've made an interior environment with only one window. It's night time and the moon can shine through the window.

However, when I try to render a video (through Sequencer, not Matinee) my results are...

1) Render is choppy/laggy.

2) Render is brighter than in the Unreal editor.

Things I've done to ensure good quality render:

1) Scalability is set to epic.

2) In Render Movie Settings for sequencer, Frame Rate set to 60.

3) In Render Movie Settings for sequencer, Resolution set to 1920 x 1080.

4) In Render Movie Settings for sequencer, Enable Texture Streaming disabled.

5) In Render Movie Settings for sequencer, Use Compression disabled.

6) In Render Movie Settings for sequencer, Use Separate Process enabled.

7) In Render Movie Settings for sequencer, Cinematic Mode enabled.

8) In General Options within Sequencer, Force Fixed Frame Interval Playback disabled.

I've read on forums that using a Post Processing Volume, which I am, can cause problems?

In my PPV, I'm using...

1) Global Illumination.

2) Bloom.

3) Color Grading.

4) Tone Mapping (specifically Tonemapper709).

5) Whatever else is turned on by default.

Other things I'm using...

1) Atmospheric Fog.

2) Light Source.

3) Point Lights.

4) Spot Lights.

5) Reflection Orbs.

6) Lightmass Importance Volume.

7) Sky Sphere.

8) Sky Light.

I suspect that when Sequencer renders, it's not taking into account the Tonemapper709 I have activated, thus making it brighter. I don't have this Tonemapper activated by default (which I think you can tell Unreal to do). Each time I load up my project I have to go into the Output Log to activate the Tonemapper. Is this a problem?

As for the choppy renders, I have no clue. My computer is pretty beefy so I'm not worried at all that it's a performance issue. However, I can't exactly rule that out, but I'm confident my computer is fine.

Product Version: UE 4.13
Tags:
more ▼

asked Apr 26 '17 at 03:29 PM in Rendering

avatar image

13lankmind
26 2 6 6

avatar image Matt.Williams May 15 '17 at 06:05 PM

Hey 13lankmimd,

This is something that has been reported before, but we haven't been able to reproduce it on our end. The speculation was that it could be something to do with the Sky Light. Any chance you can send along a project that reproduces this so that we can get it fixed on our end?

You can attach here, but if you'd like to keep it private you can PM me a download link on the forums. Please respond here if you PM me because we use Answerhub for tracking.

-Matt W.

EDIT - I'm unresolving your answer so that I can continue to track this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Well seeing how I'm pressed for time, I came with a work around. For reference, I'm working with Unreal 4.13 Sequencer. You will need (I think) an Nvidia Graphics card because they have a video/audio recording app built into their Geforce Experience desktop app. If you don't have an Nvidia graphics card, perhaps you can just download the desktop app and get the access to the recording app? But I can't confirm this.

1) Create your scene and make it look perfect. However you want to. Go nuts.

2) Create your "master" level sequencer that will hold all of your shots.

3) Create your shots and make sure they're inside the "master" level sequencer.

4) Edit shots. Magic. Poof. Play it and make sure they look exactly how you want them to. You can use play rates and whatever else you want.

5) Here comes the part with the work around. Open up your Level Blueprint and create this:

https://puu.sh/vx8KJ/a080bcd922.jpg

What this will allow to happen is when you press "Play" in your editor, your "master" level sequence will play all of your shots. You can full screen this as well by pressing F-11

6) Open up your Geforce Experience desktop app and find the recording app settings. Make them whatever you want to be. You can change file locations, hotkeys, HUD info, etc.

7) Play your video in Unreal, fullscreen, and record using Geforce Experience. This part may/may not depend how great your computer is, but as long as your video plays smooth and looks great in Unreal, you'll get the same quality through your recording. No choppy results. No weird lighting or shadows. None of that. Just a clean recording.

Hope this helps anybody out there at all with rendering out your Sequencer shots. I'm sorry if this is "noob" level advice, but I didn't know it until I spent hours scouring the internet =P Cheers everyone. I hope this does some good.

I don't know if my problem is considered a bug or not, or whether I have no idea what I'm doing (very likely). Technically this process works, so I'll make it as "answered", however the problem still exists within Unreal.

PS. If during your video, while it's playing, if you see any pesky UI elements pop up like "OMG REBUILD YOUR LIGHTING", I found another forum that shows how to disable these messages temporarily.

https://answers.unrealengine.com/questions/247674/hide-rebuild-lighting-message-in-game.html

more ▼

answered Apr 26 '17 at 08:18 PM

avatar image

13lankmind
26 2 6 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question