x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level instance multiplayer — connection lost

When you try to load a level instance, the client is disconnected from the server. If you load instance from the server's rights, then the client does not disconnected, but the loaded instances are invisible.

Disconnection occurs when setting "should be visible" to true. The same thing happens on a new test project.

alt text

Link to the test project. The logic for loading the level is in Content\FirstPersonBP\Blueprints\FirstPersonCharacter

Product Version: UE 4.15
Tags:
levelinstance.jpg (353.4 kB)
more ▼

asked Apr 30 '17 at 12:16 PM in Bug Reports

avatar image

Xelj
286 2 4 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Xelj,

I think you're running into the same issue that is linked below:

https://issues.unrealengine.com/issue/UE-43726

You can track the status of the issue using the link in order to keep an eye out for when a fix will be available.

Have a great day

more ▼

answered May 01 '17 at 07:30 PM

avatar image

Sean L ♦♦ STAFF
43.9k 485 150 438

avatar image Xelj May 02 '17 at 07:24 PM

Yes, you are right, this is the same bug. I would hope for a speedy fix.

avatar image hector-storm Jun 14 '17 at 01:19 PM

I have encountered the same issue, and dug into the code in order to find the cause. It appears the call to APlayerController::ServerUpdateLevelVisibility fails, as the client-provided PackageName cannot find a match in the UWorld's StreamingLevels array. More precisely, this array does contain an identical package name, but the Number fields of the FName objects are different, causing the equality test to return false.

avatar image Ultium Sep 08 '17 at 01:38 PM

Any fix for this issue ?

avatar image Sean L ♦♦ STAFF Sep 11 '17 at 07:05 PM

Please refer to the issues link that I posted in my original answer to check on the status of the ticket.

Thanks

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question