x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

add force/torque stop working if velocity stops

Hello, I've created a mesh and when the user presses "W" it applies a force in the forward direction. This works perfectly. However, I've discovered that if either 1) I start the scene and do not apply a force for the first 3 seconds or 2) The actor comes to a complete stop

Then further AddForce calls do not result in an acceleration. I've stepped through the blueprint and see the call the "Add Force" being hit and continuing on and I see no errors or warnings in the log files. The same thing happens with "Add Torque" which i use to turn the object. I have physics enabled and gravity disabled on the mesh. I also have it above the ground at all times so there's no friction. I'm at a loss as to what I could be doing wrong. Any help is appreciated.

Thanks

Product Version: UE 4.15
Tags:
more ▼

asked May 02 '17 at 11:31 AM in Blueprint Scripting

avatar image

bambitlaw
3 1 3 3

avatar image bambitlaw May 03 '17 at 03:47 PM

Doing a little more debugging, it seems that as soon as my net velocity drops below (GetVelocity->VectorLength) the velocity is set to 0. Once that happens, it cannot change velocity at all, be it with Add Force or Set Velocity. Same issue if no velocity is applied in the first 3 seconds of gameplay

avatar image Onoa Mar 17 '18 at 11:40 PM

Did you ever find a solution to this? I am facing the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question