x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Broken VR Debug Draw in 4.16 Preview 1 & 2

Debug draw is broken in 4.16 Preview 1 & 2, any debug draw object (BoxCollision, SphereCollision) set to render will draw a second warped black lined outline only in the right eye in VR.

Reproduction steps: Place a collision component in the level and set HiddenInGame to false, play the level in VR.

I believe that was also an issue in a preview build of 4.13 or 4.14 that has re-emerged.

Product Version: UE 4.16 Preview
Tags:
more ▼

asked May 03 '17 at 12:26 PM in Bug Reports

avatar image

mordentral
69 4 9 12

avatar image Rudy Q ♦♦ STAFF May 03 '17 at 08:35 PM

Hello mordentral,

Could you elaborate on what issue it is that you are experiencing and as to how it is at an inverse to what it is you would expect?

avatar image mordentral May 04 '17 at 01:25 AM

Any component that is rendered as a debug object has a skewed "shadow outline" of it visible in only the right eye when in VR mode as of 4.16.

I would expect this offset outline to not exist and also not be only in a single eye in VR.

avatar image mordentral May 05 '17 at 04:06 AM

Correction, they are visible in both eyes but with different offsets so they are not always visible in both.

Regardless the "shadow" copy should not exist to begin with.

avatar image Rudy Q ♦♦ STAFF May 08 '17 at 08:31 PM

I ran a few tests and I was unable to reproduce this issue on our end. Could you provide a small example project that shows the issue that you are having so that I could take a closer look?

avatar image mordentral May 10 '17 at 12:54 AM

Below is a fresh VRTemplate example from 4.16, the only change I made was to set "HiddenInGame" to false for the overlap spheres on the motion controllers.

To reproduce - open in vr preview with motion controllers and hold near face, observe extra black lines in vision.

https://drive.google.com/file/d/0B5cM3oP2O4-UeHZCdjJpaWtERWs/view?usp=sharing

avatar image Aadarsh.Patel May 30 '17 at 11:09 PM

I am also experiencing this bug in 4.16 release, just drawing normal debug lines. My current workaround is to disable "Instanced Stereo Rendering" as it only appears to glitch when that option is enabled. mordentral is right, a similar debug draw bug did appear in 4.13.

avatar image Steven.W Jun 05 '17 at 06:21 PM

Yeah got the same thing here Aadarsh. Widget interaction debug lines experience the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-44947

Make it a great day

more ▼

answered May 11 '17 at 09:08 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image Cort.Soest Jul 12 '17 at 04:45 PM

Hi Rudy,

Can we get a followup on the issue? We have a release approaching, and I wanted to see if we can get an ETA for a fix?

avatar image Rudy Q ♦♦ STAFF Jul 14 '17 at 12:54 PM

Hello Cort.Soest,

You can use the link provided above for future updates. After taking a quick look it appears there is not an ETA as of yet on when this issue will be resolved.

Make it a great day

avatar image Lemur_Hotel Sep 24 '17 at 05:05 PM

Hi this problem is still persisting in 4.17.1 Thanks

avatar image lennysunreal Sep 26 '17 at 02:17 AM

This is broken again in 4.171

avatar image Rudy Q ♦♦ STAFF Sep 26 '17 at 02:04 PM

After seeing multiple reports of this occurring in 4.17, it appears that there is some confusion with the public tracker. I double checked the link above and it appears that the current target fix for this issue is 4.18. I have provided a screen shot of the tracker as of (9/26/2017). I hope that this information helps clear things up.

alt text

targetfixhelp.png (114.6 kB)
avatar image 6r0m Oct 02 '17 at 07:52 AM

4.17.2 issue not fixed, make sure that you tested in instanced stereo enable mode.

update: sorry for bump - confused by word Fixed ( may be better create new status - Fixed in 4.18 at once together )

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question