x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor crashes on startup with Oculus, on existing project

I've been developing a Vive game using UE4 for over an year now, and I just got an Oculus Rift and wanted to port the game to that headset, so I unplugged the Vive and plugged the Rift, restarted my PC so that Unreal would stop trying to launch with SteamVR, but now, even though Oculus home is launched while the project loads, as soon as it reaches 100%, the editor crashes with this message.

Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:D:\Build++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Core\Public\Modules/ModuleManager.h] [Line: 258] Tried to get module interface for unloaded module: 'LevelEditor'

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:349] UE4Editor_UnrealEd!FModuleManager::GetModuleChecked() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\core\public\modules\modulemanager.h:258] UE4Editor_UnrealEd!UEditorEngine::GetActiveViewport() [d:\build++ue4+release-4.15+compile\sync\engine\source\editor\unrealed\private\playlevel.cpp:3475] UE4Editor_OculusRift!FOculusRiftHMD::FindSceneViewport() [d:\build++ue4+release-4.15+compile\sync\engine\plugins\runtime\oculusrift\source\oculusrift\private\oculusrifthmd.cpp:1364] UE4Editor_OculusRift!FOculusRiftHMD::DoEnableStereo() [d:\build++ue4+release-4.15+compile\sync\engine\plugins\runtime\oculusrift\source\oculusrift\private\oculusrifthmd.cpp:1382] UE4Editor_Engine!UEngine::InitializeHMDDevice() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\engine\private\unrealengine.cpp:2210] UE4Editor_Engine!UEngine::Init() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\engine\private\unrealengine.cpp:873] UE4Editor_UnrealEd!UEditorEngine::InitEditor() [d:\build++ue4+release-4.15+compile\sync\engine\source\editor\unrealed\private\editorengine.cpp:557] UE4Editor_UnrealEd!UEditorEngine::Init() [d:\build++ue4+release-4.15+compile\sync\engine\source\editor\unrealed\private\editorengine.cpp:846] UE4Editor_UnrealEd!UUnrealEdEngine::Init() [d:\build++ue4+release-4.15+compile\sync\engine\source\editor\unrealed\private\unrealedengine.cpp:75] UE4Editor!FEngineLoop::Init() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:2513] UE4Editor_UnrealEd!EditorInit() [d:\build++ue4+release-4.15+compile\sync\engine\source\editor\unrealed\private\unrealedglobals.cpp:76] UE4Editor!GuardedMain() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\launch.cpp:150] UE4Editor!GuardedMainWrapper() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:134] UE4Editor!WinMain() [d:\build++ue4+release-4.15+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:210] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

It seems like the engine can't load the level editor (the main window) because of the Oculus, for some reason. The weird thing is, however, I created a new project using the VR template, and I can load and preview the game just fine.

Product Version: UE 4.15
Tags:
more ▼

asked May 03 '17 at 05:17 PM in VR

avatar image

GMchris
73 8 8 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok I found out the answer. It's a bit odd. Here's the issue. The problem occurs when the project is set to play in VR AND you've disabled the Paper 2D plugin. I disabled it cause I wasn't using it. If you've disabled it and can no longer open your project, either use your source control to roll-back changes to your .uproject file or directly edit it's plugin configuration, where Paper2D is listed set enabled to true.

more ▼

answered May 03 '17 at 06:16 PM

avatar image

GMchris
73 8 8 14

avatar image lordmatthoffman Jun 24 '17 at 06:30 PM

Cheers, this suddenly got me and I forgot I had just enabled bStartInVR. UE-42791 is still an issue in 4.16 with Launcher version, doh!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question