x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Problem with change Multi-Line Text Box style

Hello. I try to change font style in Multi-Line Text Box widget but it not work. I finded same issue in Text Box widget and it fixed and work fine now. In MultiLineEditableTextBox.h i find this lines:

//TODO UMG Add Set ReadOnlyForegroundColor

//TODO UMG Add Set BackgroundColor

//TODO UMG Add Set ForegroundColor

//TODO UMG Add Set Font

//TODO UMG Add Set Justification

Last 3 lines very important for my project. Please implement its in current (4.16) or next version. May be you know how fix it locally?

Product Version: UE 4.15
Tags:
more ▼

asked May 04 '17 at 09:44 PM in Bug Reports

avatar image

AinTen
0 1 6 7

avatar image Rudy Q ♦♦ STAFF May 05 '17 at 07:33 PM

Hello AinTen,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you elaborate further on the exact nature of the issue you are experiencing?

  2. Can you reproduce this issue in a clean project?

  3. If so,could you provide a detailed list of steps to reproduce this issue on our end?

  4. Could you provide screen shots of any settings/blueprints/widgets/code that may be involved with this issue?

avatar image AinTen May 05 '17 at 09:06 PM

Hello Rudy,

Thanks for quick reply. I create new project in UE 4.15.2 and add widget to viewport. Multi-Line TextBox have same issues. In new project ForegroundColor work fine. Sorry for misinformation... Font attributes not changing. And "Justification" property access for read only (blueprint)...

alt text

alt text

alt text

alt text

alt text

Steps for replication

1. Create widget with Multi-Line Text Box 2. Add it ot viewport 3. Apply Set Style node to Multi-Line Text Box and change any parameters in Font node 4. Run project 5. Type some text in Multi-Line Text Box

Thanks.

gui design.png (192.9 kB)
changestylebp.png (292.9 kB)
default.png (137.1 kB)
results.png (131.1 kB)
avatar image Hermyth Dec 25 '18 at 12:11 PM

4.21 still not fixed...

avatar image Shiggi Dec 25 '18 at 01:38 PM

As you see same things in Epic code... Maybe need to update bug report for this issue. alt text

bug.png (83.2 kB)
avatar image Cucharón May 03 '19 at 07:27 AM

Wow, 4.22.1 still not fixed.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I noticed that you have more than one issue, as well as a request. I the future you will need to make separate threads for each issue/request for tracking purposes. I was able to reproduce the issues above and I have written up request to expose "Set Justification". I have provided links to the public tracker. Please feel free to use the link provided for future updates.

Style not updating:

Link: https://issues.unrealengine.com/issue/UE-44800

Set Justification request:

Link: https://issues.unrealengine.com/issue/UE-44801

Make it a great day

more ▼

answered May 08 '17 at 07:29 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image AinTen May 08 '17 at 10:01 PM

Thank you very much Rudy!

avatar image Pelangi Nov 06 '17 at 12:36 PM

Hi Rudy, was it fixed now? In which UE version? Changing the font parameter in blueprint fro Multi-line textbox was an issue from years ago, and I wonder why developers haven't fixed this very simple bug.

avatar image Shiggi Jan 10 '18 at 10:59 AM

Hi! Got this issues too. Version 4.18.2

avatar image Henrique Basto Dec 14 '18 at 02:20 PM

Also having this issue, are there any updates?

avatar image Cucharón May 03 '19 at 07:28 AM

4.22.1, still not resolved...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question