x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Landscape material

Hey,

I have a landscape master material that is dependent on slopemasks. The slopemasks applies a grass and stone material function depending on height assigned in World Machine. I can manually draw and alter these layers, and I have also added another snow layer. This is all per Futurepoly's tutorial, found here: https://www.youtube.com/watch?v=O7bUN16abUQ&t=1s. He recommends sticking to these three material functions; grass, stone and snow, but I want a 4th layer of sand which will be applied at the shorelines. I can manually draw this, but the problem arises when I plug the sand material function graph into the LandscapeMasterMaterial. The whole landscape goes grey. I have tried and tried, but I can't get the sand material to work as intended; however, if I change the material function for the graph with the Snow material function, the material renders as expected, although I'm missing the functionality. :) So I looked into the differences of the sand material and the snow material, and there's nothing that I can spot as an error; any help is most welcome! :)

Summary: Master material misfunctioning when applying a 4th material function.

This is how the terrain appears when I apply the 4th material. alt text

Graph node, showing the grass and stone MF's implemented in the master material, along with the snow. This functions as intended if plugged in. alt text

Here I have copied the snow function and made the sand function; does not work. alt text

Sand material function. alt text

Product Version: UE 4.15
Tags:
question1.png (1.5 MB)
question2.png (510.2 kB)
question3.png (479.4 kB)
question4.png (562.1 kB)
more ▼

asked May 05 '17 at 05:42 AM in Using UE4

avatar image

Devatsu
33 3 11 15

avatar image Devatsu May 07 '17 at 04:54 PM

Anyone who can help me? By the way, the master material gives me ~200 instructions. Is that a lot - I heard material functions are exepensive, but I also heard they're the way to go.

avatar image Devatsu May 08 '17 at 06:21 AM

I've tried merging the heightlerps of the snow material and the sand material and using the alpha of the grass/rock just to see if that worked, which it did not. There must be something wrong with the sand material function itself, as when I replace the sand function in the master material with for example the snow MF, then it works as expected. Strange.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You are likely to be hitting 16 texture sampler limit. Try either setting your texture samplers to Shared:wrap or use less texture samplers.

more ▼

answered May 10 '17 at 03:57 PM

avatar image

Deathrey
7.8k 130 31 292

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question