x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Copy on engine version change creates a space in the project path

This means that iOS then fails to build.

This is similar to a similar problem where the default project location is under "Unreal Projects"

 Showing Recent Messages
 [178/179] sh /Users/thomasshepherd/MM 4.15/Binaries/IOS/MM_04-IOS-Shipping
 clang: error: no such file or directory: '4.15/Binaries/IOS'

Steps to repro:

  1. From the engine project screen, open a project that is currently on a different engine version

  2. Choose Make A Copy

  3. Build for iOS

Product Version: UE 4.15
Tags:
more ▼

asked May 05 '17 at 05:16 PM in Bug Reports

avatar image

theonecalledtom
1.2k 60 63 267

avatar image theonecalledtom May 05 '17 at 05:59 PM

Sounds like a minor thing - but this means you have to rebuild the project files and then rebuild the project - which if you're building from source takes a long time!

avatar image Matthew J ♦♦ STAFF May 05 '17 at 09:30 PM

Hello theonecalledtom,

I tried reproducing this issue but I'm actually not failing, even with compiling with the project in the Unreal Projects folder. I did find a very old bug report that details the error with the space in the path itself but it is currently backlogged. This is the bug: UE-7164. Is it possible that this is specific to Source builds? I'm currently pulling 4.15 source on my Mac to test that but I was using Binary builds in particular originally.

avatar image theonecalledtom May 05 '17 at 09:40 PM

Likely specific to source builds - this was one (happens to be the first I tried so I don't have any comparison).

In this case you could change the code that generates a new name (actually would be very nice to be able to specify the name / location) to just use _s instead of spaces.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello theonecalledtom,

I apologize for the delay on this response; The fact that a space is generated when a copy of a project is made does not seem like a bug. The bug is that having a space causes problems on Mac in the first place. Please keep track of that particular bug for further information.

more ▼

answered Aug 30 '17 at 01:55 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 92 417

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question