x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dedicated Server won't boot

Hi.

I'm making a dedicated server for my game and no matter what I do the server won't start. I have the files, however the server process does not stay open.

I can't give much more info as I have no clue what it is.

Thanks

Product Version: UE 4.13
Tags:
more ▼

asked May 06 '17 at 12:04 PM in Packaging & Deployment

avatar image

snlmedia
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you running your dedicated server with -log command-line. Without that, the dedicated server will run in the background without any window. If you are simply running dedicated server without -log command line then check your Task Manager. You should see your server still running.

more ▼

answered May 06 '17 at 12:18 PM

avatar image

ryanjon2040
1.6k 56 43 93

avatar image snlmedia May 06 '17 at 12:54 PM

It's opening the process then instantly closing it again.

avatar image ryanjon2040 May 06 '17 at 01:40 PM

Could you please check the log? It should be in your Saved folder under YourGameServer/Saved/Logs folder.

avatar image snlmedia May 06 '17 at 01:51 PM

There is: Assertion failed: HasFoundDataDirectory [File:C:\Users\dell\Downloads\u4\u4\Engine\Source\Runtime\Core\Private\Internationalization\ICUInternationalization.cpp] [Line: 128] &nl;ICU data directory was not discovered:&nl;../../../../../Downloads/u4/u4/../../../Documents/Unreal Projects/Chronogon/Content/Internationalization&nl;../../../../../Downloads/u4/u4/Engine/Content/Internationalization&nl;

avatar image ryanjon2040 May 06 '17 at 03:34 PM

I did a quick Google search and I think I found the solution. Would you please try out the fix mentioned here and report back?

https://answers.unrealengine.com/questions/101935/how-do-i-deploy-a-standalone-linux-dedicated-serve.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question