x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Navmesh bounds doesn't work in android

Hello!

I have an issue with a navMeshBound Volume.

I have a NavMeshBound Volume in a landscape. When I launch my game in UE editor is all ok. Also I have a main menu and when I launch the game from this menu my IA works perfect in my NavMeshBound.

The problem appears when I try launch the game in my smartphone. If I launch the level that contents the NavMeshBound my AI works good. But If I launch the game from the main menu and I click on play button the AI doesn't do anything.

I tried move the NavMesh a bit for make a rebuild but didn't work.

I'm using android 5.1.1. and UE 4.14.3.

alt text Note: I started my project in UE 4.13 but I had to update to UE 4.14.3. I deleted the project in my PC and I downloaded it from my GitHub repository and open the project again with UE 4.14.3

Thanks and best regards!

Product Version: UE 4.14
Tags:
captura.png (38.2 kB)
more ▼

asked May 09 '17 at 08:52 AM in Packaging & Deployment

avatar image

WhyPewPew
6 1 2 2

avatar image Sean L ♦♦ STAFF May 11 '17 at 06:36 PM

Hey WhyPewPew,

I've tested this in a clean project, and I'm not experiencing the same results. Could you please reproduce the issue in a clean project and provide me with a detailed list of steps I can follow to see the issue on my end?

Thanks

avatar image WhyPewPew May 12 '17 at 10:19 AM

Hi Sean! Thanks for your answer.

Could it work that I create a clean project and copy all files from my current project into the clean project?

avatar image Sean L ♦♦ STAFF May 12 '17 at 06:33 PM

Nope, you'll need to recreate the setup from scratch. Just try the TopDown project, as it already contains a Nav Mesh and has movement that relies on it so if that works then it must be an error with the project you're currently working in.

avatar image WhyPewPew May 13 '17 at 10:17 AM

Same issue. Launching from a main menu and the NavMesh doesn't works. If I launch the game from the default map the NavMesh works in my mobile.

If I do the same in the editor the NavMesh works from main menu and from default map

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After further investigation, I do not believe this is a bug. When you launch from the editor, only the current map is cooked, which is why when you attempt to open the other map, all functionality may not be working. I'd recommend packaging the project and installing it on your device that way, as this should cook all of the maps.

Let me know if that helps.

Have a great day

more ▼

answered May 15 '17 at 03:51 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image WhyPewPew May 18 '17 at 10:46 AM

Ok.. I'll try to pack my project and try it. Thx!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question