x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Print String not printing message on Screen

Build Type - Binary Build

Build Version - : 4.14.3-3249277+++UE4+Release-4.14

Description Print String is not printing message on the screen but the message is appearing in the logs.

alt text

alt text

Reproduction Steps

  1. Add AiPerception component to third person character blueprint alt text

  2. Add On Target Perception Updated method in third person character.

  3. Try to print string containing names of ai and player character.

Initially the message was printing but after some time even simple message is not getting printed from On Target Perception Updated

System configuration

  • Operating System Windows 8.1

  • CPU Intel Core i7 4790 @ 3.60GHz

  • RAM 16.0GB Dual-Channel DDR3 Motherboard

  • Mobo MSI Z97 GUARD-PRO

  • Graphics 2047MB NVIDIA GeForce GTX 750 Ti

  • Storage 931GB Seagate

Product Version: UE 4.14
Tags:
printstring.jpg (448.1 kB)
logs.jpg (328.3 kB)
ai.jpg (116.0 kB)
more ▼

asked May 09 '17 at 04:50 PM in Bug Reports

avatar image

Freedom911
11 1 5 8

avatar image Doug E ♦♦ STAFF May 09 '17 at 06:28 PM

Hey Freedom911-

Are you making any other changes to the third person character blueprint? The On Target Perception Updated node cannot be added to the default blueprint. Are you adding any additional AI perception components or anything in code? Please elaborate on your reproduction steps to help me reproduce the issue on my end.

avatar image Freedom911 May 11 '17 at 02:30 AM

yes I have edited the question. By the way Patrolling is just a custom c++ component.

avatar image Doug E ♦♦ STAFF May 11 '17 at 04:53 PM
  1. Create new third person project

  2. Open third person blueprint

  3. Add AI Perception component

  4. Click On Target Perception Update to add event to graph

  5. Wire event into Print String node

Based on these steps I am not seeing my print message in the viewport during PIE or in the output log, however I would expect this behavior at this point because the event isn't being triggered (even after adding another instance of the third person character to the viewport). Is there more happening in your AI setup? If possible, can you provide a sample project showing the behavior?

avatar image Freedom911 May 12 '17 at 03:41 PM

Yeah sorry for late reply Here is my github link

lFinal Rockstar

In the ThirdPersonAiCharacter Blueprint I have added AIPerception component .Strangely after adding hearing sense the string is printing again

avatar image Doug E ♦♦ STAFF May 15 '17 at 07:27 PM

Hey Freedom911-

The project provided in the link does not contain any assets/map files when opened in the editor. If your print message began to appear again after adding hearing sense, it is likely that the OnPerceptionUpdated event wasn't being triggered previously.

Cheers

Doug Wilson

avatar image Freedom911 May 16 '17 at 02:19 AM

I meant to say after adding hearing sense it was working for some instances and then again it stopped working Updated my github link The map is in the content ->Level folder->ThirdPersonExampleMap.umap and AI asset is in The-Final-Rockstar/Content/AI/NPC/PatrolGuard2.uasset Link to YouTuube Video Video

As you can see the logs are getting printed but no information on screen

avatar image Doug E ♦♦ STAFF May 26 '17 at 06:38 PM

Hey Freedom911-

Sorry for the late reply, I redownloaded the project from the link to retest the issue. It seems the files in the project are getting corrupted at some point. All files show as 1KB in the project folder and don't appear in the Content Browser in the project. I had a coworker download the project as well and he saw the same behavior. Please try zipping the project and attaching it here. You can click the dropdown arrow below the comment button to make the post private.

avatar image Freedom911 May 27 '17 at 03:51 AM

Here is the google drive link link text

I noticed that Printing issue is kind of random.Like for first time if I open editor and play then string is printed,but if you keep your editor open for long time and then it stops printing.Like I pressed sleep button in my computer with my editor opened and when I came back then there was no string message.I also tried restarting the editor but still the same issue.Oh By the way I cant see option to make it private.I only see edit,delete and convert this into answer

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first

Hey Freedom911-

After further investigation, it appears this is a known issue. The root of the issue is exiting PIE while the Gameplay Debugger is active. You can find more information about this issue here: https://issues.unrealengine.com/issue/UE-41988 . This has been fixed for the latest engine version (4.16). If you're unable to upgrade your project, you can also delete your Saved and Intermediate folders. When the project restarts, your print string messages will appear again.

Cheers

Doug Wilson

more ▼

answered Jun 06 '17 at 04:52 PM

avatar image TorQueMoD Mar 16 '18 at 11:03 PM

This is happening for me in 4.18 and I've deleted Saved and Intermediate folders and it hasn't got the Print String to display again.

avatar image beableed Apr 25 '18 at 04:51 AM

Same here when using 4.191 Using Onscreen debug message. it runs through, as ive checked it with a a null return, and a Output UELOG, but no message comes up on screen. Help

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question