x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Assertion failed: !bPostTickComponentUpdate

I can join the servers fine in play in editor and standalone but when I try to seamlessly travel to a new map with packaged build I get this weird crash message that points to paperflipbook component in the engine. My game is a paper2d project and has tons of flipbook components in the source so I'm not sure how I'd go about locating the flipbook that is causing this. Crash Error: https://pastebin.com/sMRgT9Vh

It only happens to Player 2. I have 4 different computers connecting to a listen server and the first client that travels to a new level crashes while the host, player 3 and 4 travel fine.

Product Version: UE 4.15
Tags:
more ▼

asked May 09 '17 at 07:48 PM in Packaging & Deployment

avatar image

Prazon
15 13 10 14

avatar image Thomas G ♦♦ STAFF May 11 '17 at 02:02 PM

Hello Prazon,

I have a couple of questions about your issue to help me narrow down the issue you are experiencing.

  1. Does the crash for player 2 occur with a specific PC or does it happen on any PC that connects as player 2?

  2. Looking over the crash log I'm seeing an assert fail in your level1tick.cpp are there any errors in your project for this?

Thanks!

avatar image Prazon May 11 '17 at 07:52 PM

Thanks for the reply Thomas!

1) Any PC I've tried all PC's in my house (5 different ones all with win7-win10 64bit) and one at a friends place (win 8)

2) I don't use any level blueprints on my levels and it happens on any level so that error makes no sense to me. I also receive no errors when packaging, compiling, or playing. That error only appears on packaged build and not while playing in editor or standalone.

avatar image Sean L ♦♦ STAFF May 12 '17 at 07:13 PM

Hey Prazon,

I haven't run across this crash before myself when testing networking features, and it doesn't appear to exist in our database as a known issue.

In order to test this, we'll need a way to reproduce it on our end. Please see if you're able to reproduce the crash in a clean project, and if you are, provide a detailed list of repro steps that we can use to test this on our end.

If it's easier, feel free to modify the project attached to this comment in order to reproduce the issue. It already contains a basic setup for creating and joining sessions so it'll save you the time of recreating that: link text

avatar image Prazon May 12 '17 at 08:06 PM

I should clarify that it doesn't happen on connecting to a session. It happens when the server travels seamlessly to another map. I can't seem to reproduce the errors. It only started when I updated to 4.15 so I don't know what could've possibly triggered it. On 4.12 my packaged builds worked fine

avatar image Sean L ♦♦ STAFF May 15 '17 at 05:04 PM

Could you zip up your project, upload it to Dropbox, and PM me a link on the forums so I can take a look: https://forums.unrealengine.com/member.php?160394-Sean-Flint

I'd like to get a ticket in for this if I can reproduce the crash in your project on my end. Please provide a list of steps I can follow in your project to reproduce the crash as well so I know how to trigger it.

Thanks

avatar image Prazon May 16 '17 at 12:43 AM

PM has been sent! thanks for taking the time to do this

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Prazon,

Sorry for the delay. Unfortunately, the project crashed on startup for me, so I was unable to complete the test. However, I noticed you are/were using several third-party plugins, which could be responsible for the issue that you're running into since we haven't seen it on our end yet.

Integrating third-party content always comes with the risk of triggering some issue with compatibility in terms of the engine. If you are able to recreate this issue in a project that has not used plugins, then I'll be glad to take another look. At this time, we are unable to take any further action on this.

Feel free to leave a comment to reopen the thread if you discover a repro case that we can test on our end in a clean project.

Thanks

more ▼

answered May 23 '17 at 02:46 PM

avatar image

Sean L ♦♦ STAFF
43.8k 485 152 440

avatar image Prazon May 23 '17 at 11:51 PM

I've singled it down to an issue on one of my beginplay blueprints on the gamemode. I ran a print string from it displaying the class and it's printing "REINST_BP_AC_GS_MapDataMGR_Master_C_375" instead of "BP_GS_MainMenu_C_0.BP_AC_GS_MapDataMGR_Master". What exactly causes something to have "REINST_" inserted there?

cast failed # name: BP_GS_MainMenu_C_0.BP_AC_GS_MapDataMGR_Master # class: REINST_BP_AC_GS_MapDataMGR_Master_C_375 # is valid : true

avatar image Sean L ♦♦ STAFF May 24 '17 at 02:06 PM

From my understanding, REINST_ typically occurs when there is a circular dependency somewhere. I recommend using the Reference Viewer to see if you're able to discern where this could be coming from, and then you can start looking at resolving it.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question