x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Building with exclusive nativization fails

I tried using exclusive nativization with FirstPersonCharacter BP being nativized and build failed, development and release (and release for distribution).

Here is the output: https://drive.google.com/open?id=0BwE6dxM0O2PsblpVWExMQzFuZEk

I was building for Android / Gear VR.

EDIT: Tried dev build with Inclusive nativization - same story. Here is the log:

https://drive.google.com/open?id=0BwE6dxM0O2PsZFBlTlg5SDVTWTA

Does it have anything to do with FMOD ?

Product Version: UE 4.15
Tags:
more ▼

asked May 10 '17 at 01:19 AM in Bug Reports

avatar image

motorsep
378 40 48 70

avatar image Matthew J May 10 '17 at 06:07 PM

Hello motorsep,

My first suggestion would be that it could be related to FMOD. I tried doing the same thing (packaging Gear VR for Development in the FirstPersonCharacterBP with Inclusive on) and didn't get any errors or warnings. Could you attempt packaging without FMOD so that we could narrow it down if that is the cause?

avatar image motorsep May 11 '17 at 03:20 PM

I'll try, but I'd probably have to dig into my project and remove all FMOD BP nodes (otherwise building with FMOD disabled will fail).

I suspect that building stock templates will always pass as templates have no interfaces and no dispatchers.

Nativization actually used to work for me in 4.14.x (inclusive)

avatar image Matthew J May 18 '17 at 08:48 PM

Were you ever able to try removing FMOD to see if it was the problem?

avatar image motorsep May 18 '17 at 09:15 PM

Unfortunately I got entangled with release build for distribution bug and haven't been able to completely get a rid of FMOD. I'll probably have new report for you using 4.16 since that's what's going to be released soon anyway. I'll change version to 4.16 once I have results.

avatar image motorsep Jun 05 '17 at 03:43 AM

Oculus confirmed the issue is with FMOD not "wanting" to be nativized. Is it something you guys can fix or have FMOD team fix it on their side? Maybe alternatively have an option to not nativize plugins ?

avatar image Matthew J Jun 07 '17 at 02:54 PM

I can't be sure without knowing the exact reasons for it, but I would assume that this would need to be fixed on FMOD's side. As for an option to not nativize plugins, would you like to me to enter a feature request for that functionality?

avatar image motorsep Jun 07 '17 at 04:53 PM

Yes please, such functionality would be very welcomed!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I've placed a feature request in for the ability to decide if plugins should be nativized or not. It was entered under the number UE-45880. In the meantime, this seems like something that will need to be fixed with FMOD itself so that it can be nativized.

more ▼

answered Jun 09 '17 at 03:34 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question