Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Gear VR] Release for distribution build fails

I haven't built for distribution since 4.13 (and back then it worked just fine)

Finally today I wanted to build my first alpha build for Oculus Home and ... it failed. Some Oculus lib is missing apparently (I've never seen this issue before). Here is output log:


EDIT: Tried with 4.16 - same issue: https://pastebin.com/1UasbpPk

Namely yet again someone forgot to include oculus stuff into UE4:

UATHelper: Packaging (Android (ETC2)): [javac] Z:\src\com\epicgames\ue4\GameActivity.java:705: error: package com.oculus.svclib does not exist

Product Version: UE 4.16
more ▼

asked May 10 '17 at 01:47 AM in Bug Reports

avatar image

378 40 48 70

avatar image Matthew J May 10 '17 at 07:01 PM

Hello motorsep,

The users on this post seem to of encountered the same issue of that missing package:


Can you see if what worked for them may be able to help you with this issue? If not, the logs mention this warning as well:

 Warning: Oculus: Failed Oculus login. Not currently logged into Oculus.  Make sure Oculus is running and you are entitled to the app.

This could be related as it may need to be connected for signing reasons for Distribution.

avatar image motorsep May 10 '17 at 07:13 PM

Hi Matthew

That's not the issue. That warning is simply there because I closed Oculus Home since I don't need it (that's relevant to Rift and VR preview, definitely irrelevant to Gear VR development).

The issue is in missing Java classes for Oculus Online System (Oculus confirmed). Supposedly Oculus pushed fixes, but I don't know whether they did it for their branch or into Epic's master.

It would be nice if those fixes, if those are indeed the fixes, end up in 4.15.3 (ot some hotfix for 4.1.5) too.

avatar image Matthew J May 10 '17 at 07:19 PM

Glad to hear you already know what the actual issue is. We don't currently have any bug reports in related to this, as far as I can find at least, as well as no other reports. I don't see it likely that this would be fixed in a hotfix if it is indeed a bug.

As you mentioned that Oculus has confirmed that this is the problem, could you provide a link to that confirmation for additional information?

avatar image motorsep May 10 '17 at 07:23 PM


Just out of curiosity - shouldn't be thread marked as resolved when the issue is actually resolved? (or recorded into your system with a reference link where users can track progress)

This bug is critical as it prevents releasing on Oculus Home for Gear VR and potentially for Rift.

avatar image Matthew J May 10 '17 at 07:26 PM

As with all answerhub posts, the thread is automatically marked as resolved when an answer has been posted by a staff member. Just because it's resolved doesn't mean I'm done looking into it. It's only for tracking reasons.

avatar image Matthew J May 10 '17 at 07:36 PM

As for this being critical, one thing to note is that, if this is particularly blocking you at the moment, I would suggest using the Github build as suggested by the Oculus Staff members to have a working version in the meantime. I'll escalate this to see if we can get it into the hotfix. I'll keep you updated here.

avatar image Matthew J May 10 '17 at 08:03 PM

Before I can do something about getting this reported, I need to have a reproduction. I attempted to reproduce this by using the Blueprint ThirdPersonExample template.

  1. Enabled the "Online Subsystem Oculus" plugin

  2. Disabled the "Oculus Rift" plugin (tried with it enabled as well, just in case)

  3. Set the Android SDK to 19, set minimum SDK to 19

  4. Enabled "Configure the AndroidManifest for deployment to GearVR"

  5. Moved the Keystore over to the project and filled out those settings.

After doing that, I attempted to package with For Distribution enabled ( already had my .osig from previous projects) and was able to do so without any errors. Is there anything that I may of missed that could help reproduce this?

avatar image motorsep May 11 '17 at 03:14 PM

Well, did you have BP entitlement check node in your project ?

I can try removing that node and see if it builds for distribution. Also, just having Online Susbystem Oculus enabled doesn't do it - defaultEngine.ini in the project folder has to be edited to enable it.

avatar image motorsep May 11 '17 at 03:12 PM

I built engine from source from Oculus branch - when loading my project engine told me it was created in a different version of UE4 and thus required to be converted. So I did that on a copy of my project. Then it turned out that it's not compatible with FMOD, which puzzles me - FMOD for 4.15 should work fine on both launcher's and Oculus' branch, but it doesn't.

avatar image motorsep May 12 '17 at 01:01 AM

I disabled Oculus Online System, and I still can't build it :(

Also disabled Oculus Rift plugin, and now UE4 hangs when opening my project with the following error:

alt text https://s29.postimg.org/u5py4mx2f/ue4_vr_error.png

To be clear - I have Rift (and thus Oculus Home is installed), but currently I develop for Gear VR

avatar image Matthew J May 12 '17 at 05:54 PM

I was able to find a post about that error, if any of the information there may be able to help you. Unfortunately, none of the users came back to confirm if it helped or not.

When you fail building with the Online Subsystem Oculus plugin disabled, do you get the same error messages as before?

avatar image motorsep May 12 '17 at 06:06 PM

No, when I disable Online Subsystem Oculus I get no error. I only get that error when I disable Oculus Rift / Steam VR plugins. I also never hard this issue before I installed Rift / Steam VR software. Maybe UE4 trying to communicate with VR software and not being able to because plugins are disabled?

avatar image motorsep Jun 02 '17 at 04:52 PM

I updated OP - same issue in 4.16.1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Props to the folks from https://answers.unrealengine.com/questions/489703/android-gear-vr-shipping-distribution-package-fail.html

I was able to resolve the issue by commenting out a small block in GearVR_APL.xml in ..\Epic Games\UE_4.16\Engine\Plugins\Runtime\GearVR\Source\GearVR\


Since I use manual entitlement check using respective BP node, I figured that won't hurt anyway.

Ideally this should have been fixed by Oculus/Epic a few revisions back. Hopefully either next hotfix or 4.17 will have this issue fixed.

more ▼

answered Jun 02 '17 at 09:08 PM

avatar image

378 40 48 70

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question