x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Materials are black on 4.14+

I am attempting to upgrade my project, but I can't get it past 4.13 without most materials on my meshes turning black (or transparent?). I have tried 4.14.3 and 4.15.2.

I am willing to provide a download link for the project to Epic Staff to debug if that helps!

Here's what it looks like in versions

alt text

And here is what it looks like in versions >= 4.14 (note that some materials survive, but most are black)

alt text

I have:

  • 2 directional lights (no other lighting)

  • a post-process volume

  • An orthogonal camera

  • And simple materials like this (this is the body color of the spaceship):

alt text

Product Version: UE 4.15
Tags:
more ▼

asked May 10 '17 at 01:36 AM in Rendering

avatar image

CleanCut
2.1k 67 84 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Did you tried to rebuild lightning?

In 4.15 it uses additional _BuildData map to store lightning information.

If editor not find this asset for your map, everything that lit statically will be black

more ▼

answered May 10 '17 at 02:58 PM

avatar image

redbox
4.3k 82 20 104

avatar image CleanCut May 10 '17 at 04:20 PM

I rebuilt lighting. It made no difference in 4.14 or 4.15. :-( Thanks for the suggestion, though! Any other ideas for what I could try to fix it?

All my actors are placed dynamically during runtime, so I would have been surprised if building lighting made any difference anyway:

alt text

avatar image redbox May 10 '17 at 06:34 PM

There was some changes with tonemapper, so maybe you need to check post process settings.

Both directional lights are movable?

avatar image CleanCut May 10 '17 at 07:39 PM

Aha! That was it! The directional lights' own mobility was set to static. That worked fine in 4.13 and earlier. Changing it to Movable fixes it in 4.14 and 4.15.

Thanks! You're my hero today. :-)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question