x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Light Propagation Volume does nothing in 4.15.2

alt text

I've followed multiple guides (most of which all give the same steps) to set up light propagation volumes. I've done this both in my project as well as a brand new fresh project. Above is a test scene with all of the LPV steps completed and the LPV visualization turned on. No settings (Intensity, et al) make any difference. Setting the SkyLight to movable makes all shadows pitch black. No light is bouncing.

Are light propagation volumes broken in 4.15? Am I doing something totally wrong? Any help is appreciated!

Product Version: UE 4.15
Tags:
lpv1.png (913.3 kB)
more ▼

asked May 10 '17 at 05:14 AM in Rendering

avatar image

mutatedjellyfish
1 1 2 1

avatar image Unhek May 12 '17 at 10:22 PM

can you tell me what exactly was the issue? I also cannot get lpv to work atm yet all settings seem to be correct, even after checking the console in editor to verify

avatar image mutatedjellyfish May 12 '17 at 10:32 PM

I had all the right settings and checked all the checkboxes. UE even appeared to generate all the data when I switched lightmaps off, but light wasn't bouncing and no LPV settings in the post process volume would have any visual effect whatsoever. Turning on LPV visualization would bring up text info but no actual visual data.

The problem was I had similarly-numbered versions of UE4 installed in Program Files (x86) and that is where I added the console variable. Once I added the console variable in the correct folder where I was actually running the engine from it all worked.

avatar image Unhek May 12 '17 at 10:34 PM

hmm, I'm sure the setting it set because the console says it is. lights are movable, dynamic gi is set to on. post is boosted, nothing works :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

It works fine for me.

There is one problem that to enable it you need to add r.LightPropagationVolume = 1 to ConsoleVariables.ini in engine folder. But sometimes it removed from that ini, maybe by editor or I don't know.

I tried to add this file into project config folder but that didn't work.

more ▼

answered May 10 '17 at 12:19 PM

avatar image

redbox
4.3k 80 17 104

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Nevermind, I'm an idiot. I have duplicate UE4 folders in completely different places. Thanks for the help regardless!

more ▼

answered May 10 '17 at 09:15 PM

avatar image

mutatedjellyfish
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question