x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Perforce Sync not refreshing properties in Content browser and scene

Hi,

we managed to set up perforce to work with Unreal Engine 4 and as it seems, we got mostly everything right. The Source Control of the Editor successfully connects to the perforce server and we are able to commit and checkout things inside the content browser. All connected clients also get feedback about the current status of assets (whether they are checked out or not). Unfortunately, we do have some issues with the Syncing of changed assets. For example, client A checks out a material and changes it's color. Client B wants to work with that material as well, sees, that it's already checked out and thus waits for client A's commit. Afterwards Client B syncs the material (the exclamation mark disappears) and is now thinking, that he sees the correct, current version of said material. Unfortunately, the Material changes aren't yet propagated to his content browser. If, for example, the diffuse color was changed from green to white, the material in the content browser of Client B after synching is still green. He needs to close and reopen the whole edior to see the correct version of the material with the now white diffuse color.

Is this really how it is supposed to be? Are we missing any point?

Thanks and best regards

Product Version: Not Selected
Tags:
more ▼

asked Jun 23 '14 at 08:34 AM in Bug Reports

avatar image

LeFxFlo
177 9 16 23

avatar image 4everwilliam Jan 09 '15 at 12:11 PM

Getting this exact issue as well. Pressing "synch" in source control drop down menu does not do anything. We also need to close and reopen the whole unreal editor to get the correct updated version of whatever was checked in. Any plans of fixing it or does anyone know some solution?

avatar image DragonHunt10 Feb 10 '15 at 04:50 AM

Same issue, Syncing sometimes works, sometimes doesnt refresh, and i have to close the editor and relaunch it to get the changes.

avatar image erinacea Aug 16 '15 at 04:36 PM

Any news on this?

Still happens in 4.8.3 and with svn. We've only been using Source Control (Subversion) for four days and already had at least one case (that we noticed) where one developer accidentally overwrote another one's changes in a Blueprint they'd both properly checked out and committed (one after the other, the second starting work after syncing the first one's changes).

As stated above, after closing and reopening the editor, everything is fine. Updating the revision in an external tool (TortoiseSVN), then opening the editor also works. (Updating externally with the editor open usually fails because "files are already in use".)

avatar image Ben Halliday STAFF Aug 24 '15 at 05:56 PM

Hey erinacea,

Not much of an update except to say that they're still actively working on solutions, and tracking it generally as UE-6308. The scenario you described is specifically part of the bug report. It looks like parts are fixed for Blueprints, but that fix needs to be checked against all other asset types, and this is going to take time (and resources). I'll update here when I see anything get checked in.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi

This looks to be something we've overlooked, so I'll file an issue to get it addressed. We would want to re-generate the thumbnail for the asset in question.

more ▼

answered Jun 23 '14 at 08:47 AM

avatar image

Tom Sarkanen STAFF
1.7k 39 12 53

avatar image LeFxFlo Jun 23 '14 at 09:48 AM

Thanks for the immediate reply. But please consider, that it's not just the thumbnail. The material itself doesn't get properly refreshed. If you double-click it to open it in the editor, the "old" values are still there. Right now we actually need to close and reopen the whole unreal editor to get the correct, updated version of the material.

avatar image Tom Sarkanen STAFF Jun 23 '14 at 09:51 AM

Thanks - I'll make a note of that in the issue.

avatar image hyperdr1ve Nov 19 '14 at 01:19 AM

We are also hitting this teething issue with perforce. It seems like the file itself is synced on the filesystem but not refreshed in the engine. If you restart the editor, it will pick up the change.

I'm on 4.6 preview and looking through the repo and don't see any changes to this for the last month. Is this still on the list? Assuming I'm looking in the correct location: UnrealEngine / Engine / Source / Editor / SourceControlWindows

avatar image iaanus Dec 15 '14 at 01:52 PM

Definitely, you should fix this. I am going to teach people to disable P4 integration. It's very much safer not using it, if this bug is around, since it provides a false sense of security that only brings disasters, anger and distrust in the system. Things you really do not like to have on your project.

avatar image CobraVXV Feb 07 '15 at 08:53 AM

Any solutions thus far to fix this? Properties are only updating when the Unreal Editor is restarted...this is incredibly inconvenient.

avatar image Tom Sarkanen STAFF Feb 09 '15 at 09:37 AM

No solutions as yet unfortunately, I have bumped the thread we are having on this internally however!

avatar image Marktopus Feb 19 '15 at 01:39 AM

Experiencing the same issue! It makes development take exponentially longer because we have to wait for the editor to restart every time we want to work with an updated asset.

avatar image Thor Apr 02 '15 at 07:07 PM

After setting up some repro cases on my end to investigate similar errors, my team has also been running into this. It ended up causing a lot of unseen problems with different designers overwriting each other's work without knowing. Closing and reopening seems to be the less than ideal workaround.

avatar image Ben Halliday STAFF Apr 13 '15 at 06:08 PM

Hi all,

This issue is still being looked into, and my understanding is a possible fix still needs a lot of testing. I have updated the community interest on the bug report (UE-6308). Thanks for your patience!

avatar image IEQI May 07 '16 at 12:20 PM

Version 4.11 and still no fix? This is still a major issue when trying to work in a team!

avatar image Adam Davis STAFF May 09 '16 at 06:57 PM

Hi IEQI,

This is still under assessment by the development staff. Unfortunately I do not have a timeframe of when a fix will be implemented as our resources are currently dedicated elsewhere. I have updated the bug report to reflect that additional developers are experiencing this error.

avatar image iaanus May 27 '16 at 10:29 AM

"Our resources are currently dedicated elsewhere."??? What's wrong with you guys? This is a major issue and hasn't got any attention in years. This is the kind of features developers wants to be be fixed because they have impact on the every day workflow. Unfortunately it's not fancy stuff that looks good on the website, which is clearly the force that's driving your priorities... Sigh!

avatar image thevfxguy13 Nov 01 '16 at 05:35 AM

Just started using Perforce tonight with a small team and immediately noticed this issue. Any updates?

avatar image thevfxguy13 Nov 01 '16 at 05:36 AM

From another post https://answers.unrealengine.com/questions/477322/perforce-syncing-does-not-update-ue4-content-brows.html

Hello Wheeze,

We've had a few other users report this issue as well and I've previously placed a bug report in for this. You can find it here: UE-20789. Unfortunately the only workaround at the moment is to restart the editor. Please feel free to vote on the report so that we know people are interested in getting it fixed, and hopefully make it more of a priority. more ▼ Newest

answered Aug 30 '16 at 12:23 PM Matthew Clark gravatar image

Matthew Clark ♦♦ STAFF 19.7k ● 405 ● 37 ● 297

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question