x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Need to mute sound class, can still hear sound when volume is 0

Hello! I've checked similar questions on the forums here, but they either don't have an answer or the answer doesn't seem applicable. I have two separate sound classes, one for sound effects, and one for music, that I'm modifying using Set Sound Mix Class Override to change the volume from an in-game menu. I'd like to be able to totally mute either of these sound classes, but setting the volume to 0 doesn't mute them, just makes them very quiet. Even setting the volume to something absurd like -100 doesn't solve the problem. As far as I can tell there isn't any other way in blueprint to adjust a sound class except through sound mixes, so I am at a loss. Is there a way I can actually mute a sound class in a blueprint?

Product Version: UE 4.15
Tags:
more ▼

asked May 11 '17 at 04:54 PM in Blueprint Scripting

avatar image

jevans_wahoo
1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Have you found any solution for that problem?

more ▼

answered Dec 06 '17 at 09:34 AM

avatar image

RuWhyNot
57 5 10 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Same problem here. "Fade in time" is broken, looping meaninglessly. And sound mix at volume 0 doesn't mute anything, sound becomes weirdly distorted.

I will test some more, but it's totally broken. If you have any solution, share it with us. Used version 4.21.

more ▼

answered Jan 23 '19 at 07:40 PM

avatar image

Taberu
191 4 11 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

WORKAROUND:

In Sound Mix editor, go to "Sound Mix" tab and change the Duration to something positive, probably something longer than your longest SFX. I'd love to sound smart, but I have no idea what's going on. It might have something to do with played track duration as I tried to mute very short (~0.3ms) ones. I hope it will work for you too! Try to test it further if you can and post a bug report, please.

more ▼

answered Jan 23 '19 at 08:05 PM

avatar image

Taberu
191 4 11 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question