x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

This is the Error Code I Cannot Fix: {SM5} (NodeTextureSampleParameter2) Param2D> Requires Texture2D

I recently purchased this asset pack off the marketplace: https://www.unrealengine.com/marketplace/research-center I was able to open the demo project perfectly fine, but when I tried to import assets into my own project, I couldn't. Elsewhere I read that it isn't possible to import .uasset and .umap extensions. So I moved over the files into the project directly on the hard drive, which worked.

Yay! I finally moved over my purchased assets into my own project! But my current problem is this: I cannot drag and drop anything from my content browser into my level editor. Each time I drag something, it turns to the grey checkered ball and I can't do anything with it.

When I click edit on anything I added to the content browser from the Research Center I bought, it always shows the error, "{SM5} (NodeTextureSampleParameter2D) Param2D> Requires Texture2D" I don't know how to fix it.

I have found very little on how to solve this problem. Also, I am relatively new to game development, so I am not 100% clear on all the lingo and terminology, so please try to explain things as simple as possible.

Please help me, this is driving me insane!

Product Version: UE 4.15
Tags:
more ▼

asked May 12 '17 at 05:53 AM in Using UE4

avatar image

crazyjdog1
1 1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It looks like you just copied assets into new project, but missed folders structure or location. As result - meshes can't find materials, and materials can't find textures. You should open project you purchased, select required assets, press right mouse button and select "migrate" option. Then specify "content" folder of new project.

more ▼

answered May 14 '17 at 02:17 PM

avatar image

redbox
4.3k 81 19 104

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question