x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Failed to find /Engine/EngineMeshes/Cylinder

Hello everyone. Today I tried to package my android game, and everything went alright. I used the install.bat to install my game, and it was successfully installed. But when I open it, it gives me the following error message:

Default Property warnings and errors: Error: CDO Constructor (VehicleWheel): Failed to find /Engine/EngineMeshes/Cylinder

Do you need extra info?

Product Version: UE 4.15
Tags:
more ▼

asked May 12 '17 at 07:28 PM in Packaging & Deployment

avatar image

AzorMachine
3 1 7

avatar image AzorMachine May 12 '17 at 08:03 PM

My log:

link text

log.txt (7.3 kB)
avatar image AzorMachine May 15 '17 at 12:27 AM

My packaged .apk was working fine, but after working a week in my game without packaging for tests, this happened. First, I had three errors: "This project requires the PluginBrowser plugin" & "This project requires the VisualStudioSourceCodeAccess plugin" & the error I told about in my question. The two plugins mentioned were enabled and working. But, for some reason they weren't being packaged with the game. With those in mind, I disabled those plugins. Now the only error I have is "Error: CDO Constructor (VehicleWheel): Failed to find /Engine/EngineMeshes/Cylinder"

avatar image AzorMachine May 15 '17 at 05:34 AM

Oh, it is important to note something. Although my error says : "Error: CDO Constructor (VehicleWheel): Failed to find /Engine/EngineMeshes/Cylinder", my game don't even uses vehicles!

avatar image yuwangrainking May 17 '17 at 08:00 AM

Got same promblem after update to UE4.15.2.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey AzorMachine,

I recommend a few things in this situation:

  • Try packaging a clean project to see if you get the same errors. If those plugins aren't working, it's possible that you may have removed some necessary files somewhere, or they got corrupted somehow.

  • Try reinstalling the engine version that you're using, or try installing a later version such as the 4.16 Preview and upgrading a copy of the project to that version to see if the same error occurs. If that works, then it's likely that those files were removed somehow and you'll need to reinstall the engine.

Let me know the results.

Have a great day

more ▼

answered May 15 '17 at 06:29 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is caused by the PhysXVehicles plugin. Somehow the plugin file is being added to the apk, even though it's disabled. Re-enabling the plugin solves the problem, but I believe this is a bug - that plugin should not be required.

more ▼

answered Jul 10 '17 at 03:03 AM

avatar image

RicarDog
78 3 5 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question