x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

trying to build lighting only gets stuck on "Starting up Swarm Connection...(100%)

My scene is tiny and shouldn't have any issues but it instantly freezes and I have to close UE4 from task manager. Building lighting only used to take a few minutes and it got annoying so I looked for a fix. I seen people say that in Swarm change EnableStandaloneMode = false to EnableStandaloneMode = true. I tried changing it back but got a error message saying: https://gyazo.com/2ca52dc09dd343b2dd6fe4437bad67bd and it didn't matter which option I had it on, true or false gave me the same error message.

I asked on Discord and was un able to get this issue solved.

I even tried to create a brand new first person shooter scene and build the lighting in there and it gave me the same freezing issues.

Scene: https://gyazo.com/e617922b364f988125b1a4bb77b8bef6 Log: https://pastebin.com/qkwkKzMk

Product Version: UE 4.15
Tags:
more ▼

asked May 14 '17 at 02:34 AM in Using UE4

avatar image

Ffivee
1 1 1

avatar image Ffivee May 15 '17 at 02:22 AM

I just loaded the project up and clicked build lighting only again and it froze. So I double clicked Swarm and then it built the lighting and worked. I didn't change anything beside restarting my PC and that seemed to have fixed it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Looks like either Swarm isn't starting up or the comms are being disrupted. Check to see if Swarm is running when you build the lighting. If it is then it's probably a port being blocked or some other TCP kind of issue. If it's not then, well, there's your problem. Either way, it will be hard to diagnose without more information. Figure our which diagnostic path we need to take and we can go from there.

I can tell you that the one time this happened to me, for some reason the UnrealLightmass project was not being built with the rest of UE4. You could try going into the UE4 project and building it manually (right-click on the project and select Build). Long shot, and assumes you're using a source-built engine, but worth mentioning.

more ▼

answered May 14 '17 at 02:53 AM

avatar image

Jin_VE
4.4k 32 77 41

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question