x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I am not able to Re-Import Static Mesh with new Sockets.

I am trying to re-Import A staic Mesh via Maya "send to Project", it would be very comfortable to have an import setting (In UE4) wich would allow me to reimport Socket's totally. I prefer using my 3d program to attach/delete sockets' etc. I even installed 4.15 beause there was in Trello Roadmap written that this issue would be solved, but it seems not.

Product Version: UE 4.15
Tags:
more ▼

asked May 14 '17 at 09:01 AM in Bug Reports

avatar image

NR6
42 2 3 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey NR6,

We had someone test this on Maya and they only reproduced the issue when using the "Freeze Transformations" option in maya, this will cause the sockets to appear in the wrong location.

Otherwise re-importing the asset with updated sockets appears to be working as expected as of 4.15.

Cheers,

Ed

more ▼

answered May 16 '17 at 07:34 PM

avatar image NR6 May 17 '17 at 05:13 AM

Hello,

Thank you for your Answer,

So the Socket's are good placed when importing for the first time or after deleting the Asset Manualy and the FBX file in the UE4 Content Folder. but i would not consider that as an clean way of re-importoing. Again the socket placement works for the first Time but when doing some changes in Maya and to the socket placement within the FBX file, and than sending it via (set project UE4) and "send to Project" . After doing some changes in UE4 with the socket Tool it will not change the Sockets in UE4 . It may look that the placement of sockets changed if u move the Pivot, mayby he did something like this, because the model can be changed.

Also was he able to set an minus scale with the imported Socket for Only on Axis ( FE. 1,-1,1 ) ? \

...

Here Is An total Another Problem:

UE4 Blutility, Giving An Static Mesh an -Scale X or/and Y or/and Z, results an weird behavor of Model(The Upper Image is when i did one of the a b c steps, the down image shows the models( Yellow )( This happens to a variety of difrent models ), it can be solved in Editor with:

a) Sometimes using the Play/Stop Button

b) When changing the Relative Scale Into Absolute Scale

c) Sometimes when altering the Scale Values or pressing "Enter" with them

**PS.**Also an Tool or the posibility to add (Drop And Drag "like") multiply Static Meshes into Array or the posbility to show an Folder or Pointer wich could be in an Folder to say please add all this meshes to This Static Meshes Array. To Take it Short: Some Way to Control Assets in a Larger Way.

Cheers Again

alt text

avatar image Thomas G ♦♦ STAFF May 18 '17 at 06:30 PM

Hello NR6,

I am the one who tested your issue on our end. I have a couple of questions to help me investigate your issue further.

On my end to test your issue I am using the following steps:

  1. Create a new scene in Maya 2016

  2. Add a cube primitive, set location to 0,0,0

  3. Set the Cube's Name to TESTCUBE_01 (for both transform and mesh)

  4. Under the rigging category, I am adding a locator set location to 0,150,0

  5. Name the locator SOCKET_TESTCUBE_01 (for both transform and locator)

  6. Parent the Locator to TESTCUBE_01

  7. Delete all by type history

  8. Export All as an FBX

  9. Import the FBX into UE4 and open the file (Expected Result)

  10. Back in Maya, I Add a new locator at location 150,0,0

  11. I named this locator SOCKET_TESTCUBE_01_00 (for both transform and locator)

  12. Parent the new locator to TEST_CUBE_01

  13. Delete all by type history

  14. Export All as the same FBX

  15. I use the reimport option in UE 4

  16. Open the file In the mesh viewer there are now 3 sockets 2 are SOCKET_TESTCUBE_01 and the other is SOCKET_TESTCUBE_01_00

  17. The sockets in the expected locations

So couple of questions for you

  1. How does my test case differ from your process?

  2. You mention in your post making changes in the socket tool on UE4's end, what specific changes are you making?

  3. Can you post screenshots of your issue?

Lastly, your issue with Blutility, seems like a separate issue, We ask that you create a separate post for separate issues to help with tracking on our end.

Thanks!

avatar image NR6 May 18 '17 at 07:42 PM

Hello, I will do that on monday! Thank You.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question