x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to avoid Cloth generated artifacts when teleporting Skeletal Meshes? (using Level Sequencer)

Hi everybody, this is my first question here.

I'm having a bit of a problem with my Sequences. I have a Character with Skeletal Mesh and Clothing that I use as a Possessable Actor from the Level Sequencer to play various animations during my game. (For design reasons my Character cannot be spawned by the Level Sequencer)

The problem is that when the Possessable Actor gets possessed and translated immediately to great distances, the cloth management system results in some artifacts during the translation (wich is instant!).

Specifically, I see what seems to be like stretched meshes from the origin of the translation to the actual final position.

I know it is related to Cloth because if I deactivate it (set Disable Cloth Simulation) there are no wrong graphics displayed when I start my Sequence.

I would like to have my Cloth simulated during the sequence though! I tried re-activating Cloth Simulation AFTER starting the sequence (just using a Delay and setting to false Disable Cloth Simulation after Playing my sequence), but it seems that Cloth Simulation doesn't get updated, so I have no way to turn on Cloth Simulation after my sequence started.

I also tried to play a bit with the "Force Cloth Next Update Teleport" and similar nodes but with no result!

I really want to have Cloth simulated during my Sequences... can you give me some insights on how this works?

Thank you

Product Version: UE 4.14
Tags:
more ▼

asked May 17 '17 at 10:15 AM in Blueprint Scripting

avatar image

Q-tro
93 4 3 14

avatar image Q-tro May 23 '17 at 03:56 PM

Sorry for the BUMP! ^_^'

avatar image LightDraven May 24 '17 at 07:27 AM

I'm having the same problem. This Engine is a continuous delay.

avatar image CanadianGuy43 May 26 '17 at 05:58 PM

Also running into this, any help would be awesome!

avatar image Q-tro Jan 08 '18 at 03:28 PM

Any news on this? :(

avatar image Safanaff Apr 17 '18 at 07:46 PM

Would be really nice to have an update for this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just to let you know that migrating to 4.18 resolved just by itself a lot of situations where those "cloth stretches" where very visible during SkeletalMesh translations.

That, and the new in-editor cloth painter worked wonders: specifically in making cloth simulation visually better and allowing devs more options for optimizations.

Marking as answered.

more ▼

answered Jun 21 '18 at 07:14 PM

avatar image

Q-tro
93 4 3 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question