x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GPU Particle collision works in editor but not in game

Hello,

GPU Particle collision has stopped working in my main project when playing the game. Particle Collision works fine (both Scene Depth and Distance Field) in the editor, but when using PIE or a Standalone Game, neither collision type works and the particles pass through all objects.

If I make a new 4.15.2 project, GPU collision works in editor and in game. GPU Particle systems which work fine in game in new projects (e.g. the Content Examples GPU Particle system) don't collide in game when migrated into my main project, as shown below:

alt text

alt text

All scalability settings are on Epic. Things were working OK until very recently and there are no asset changes I can see which would account for this problem. Are there any PIE or Play-specific scalability or particle settings which may have been altered? Or any other project settings which might account for this problem?

Grateful for any suggestions.

Product Version: UE 4.15
Tags:
more ▼

asked May 18 '17 at 10:25 AM in Rendering

avatar image

Rob McLachlan
49 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

OK I have discovered the reason - I have a Scene Capture Component 2D attached to my character for an inventory viewer, and this is disabling GPU particle collision as described below:

https://answers.unrealengine.com/questions/565904/gpu-particle-collision-stops-working-when-adding-s.html

https://issues.unrealengine.com/issue/UE-42443

I shall vote and hope for it to be fixed...

more ▼

answered May 19 '17 at 04:04 PM

avatar image

Rob McLachlan
49 6 9

avatar image Rob McLachlan May 19 '17 at 05:31 PM

If anyone is interested in how to workaround this problem:

I have an inventory system with a HUD widget that renders output from a Scene Capture Component 2D. This component is on a blueprint spawned off the character far outside the skybox. What I do now is disable ticking of the capture component on beginplay, and only re-enable ticking of it when the inventory 'inspection' window is activated on the HUD.

This means GPU Particles now collide correctly during gameplay.

avatar image xcloudx01 Aug 08 '18 at 12:55 AM

Thank you so much for your solution. I have the exact same problem and your fix worked!

avatar image GRIMSK Mar 01 '19 at 05:29 PM

but what if the HUD should be always activated..? got any ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question