x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird Rounded LowPoly Shadows

Hello everyone, I'm 2 days into Unreal Engine so you can tell i am pretty new to everything, i did the tutorials and watched alot of videos. I was taking the first person template and deleting the map out of it. I then created a wall and a wall detail with BSP, afterwards i converted it into static meshes. My Problem: Weird shadows as in the following picture alt text Were cast. I built the lighting already but i couldn't figure out whats the problem. (editor is also set to production). Any help would be greatly appreciated! :) *Edit i just discovered that i could walk through these walls? Where do i change this.

Product Version: UE 4.15
Tags:
more ▼

asked May 18 '17 at 02:55 PM in Rendering

avatar image

stupidlogin
1 1 2 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I found the fix myself. The wrong UV-Map was selected and collision deactivated, as usual with BSP objects apparently. Increasing shadow maps will increase accuracy of shadows too. And use cascade lightning. Good video on this for everyone having problems: https://www.youtube.com/watch?v=WDM9ir3NZH4

more ▼

answered May 18 '17 at 04:39 PM

avatar image

stupidlogin
1 1 2 3

(comments are locked)
10|2000 characters needed characters left

You can select floor mesh, find option Override Lightmap resolution, and set it to 128 for example. this will give good resolution for shadow.

Or you can select directional light, and enable cascaded shadow maps in it. this will enable dynamic shadows on specified distance

more ▼

answered May 18 '17 at 03:05 PM

avatar image

redbox
4.2k 80 16 103

avatar image stupidlogin May 18 '17 at 03:13 PM

When i do so it makes the material go really weird too.alt text

screenshot_1.png (1.3 MB)
avatar image stupidlogin May 18 '17 at 03:18 PM

With floor mesh, you meant the plane? ok i did so and increased the shadow res of the plane only and it creates this weird rounded half correct shadows alt text

screenshot_2.png (890.1 kB)
avatar image redbox May 18 '17 at 04:18 PM

Its lightmap. It will be simplified with low resolution. You can set it to 1024 or 2048, but then its memory cost will be increased dramatically.

Better enable Cascaded shadow maps

avatar image stupidlogin May 18 '17 at 04:40 PM

i found out what it was, thanks for your help anyways :) !

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question