x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to disable tonemapper without removing all other post processing effects?

Hi, I would be very glad if someone can help me find a solution to this problem.

I am trying to use unlit materials to create a stylized art style. The problem is that the tonemapper completely destroys the colors and values of the textures I've painted in photoshop. I've tried to disable the tonemapper using a console command in the level blueprint, while it does work it will also remove all the other post processing effects such as bloom.

Surely there has to be a way to get the correct colors without ruining everything else? I've looked around and some other people seem to be dealing with the same problem. I could not find a solution that works for me.

Your help is appreciated!

alt text

Product Version: UE 4.15
Tags:
more ▼

asked May 20 '17 at 11:13 PM in Rendering

avatar image

Unrhyme
28 3 4 8

avatar image dustintinkler Sep 28 '17 at 02:20 PM

I am also having this issue. Please someone help!!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think you might be disabling the whole tonemapper, while what you should be doing is disabling only the new "improved" filmic tonemapper epic added in 4.15 and up (it seriously messes up with emissive colors). The best way I know to do this is to go into your project files, in the config folder, open the DefaultEngine.ini file and add the line

r.TonemapperFilm=0

under the [/Script/Engine.RendererSettings] section (copy and paste the line in bracket and add the r.tonemapper line under it if you dont have it in your file yet)

This will revert unreal to the old tonemapper, which can still do some... strange things to colors sometimes, but much less than the "physically acurate" filmic tonemapper while still allowing you all the other post process stuff like bloom, DOF or motion blur.

(Epic said they'll remove the option to use the old tonemapper in a futur update eventually but I'd say lets all tell unreal we DON'T want that please? I know some of you are reading these. We need still need the old tonemapper for more cartoony stuff!)

more ▼

answered Sep 29 '17 at 02:45 AM

avatar image

Chime
124 3 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question