x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AutomationTool fails with 1: Client target not found

Hi, I'm currently making a small game to learn the basics of UE4. Everything was working correctly, but I was only able to package my project once. After that I started receiving errors on Shipping builds (does not happen on Development):

The cook platform was always WindowsClient. I've already tried reinstalling UE4 and migrating the assets to a clean project. Here is the output log:

 Running AutomationTool...
 Automation.ParseCommandLine: Parsing command line: -ScriptsForProject="D:/Simon/Unreal Engine Projects/SlowMotionProj/SlowMotionProj.uproject" BuildCookRun -project="D:/Simon/Unreal Engine Projects/SlowMotionProj/SlowMotionProj.uproject" -noP4 -clientconfig=Shipping -serverconfig=Shipping -nocompile -nocompileeditor -installed -ue4exe=UE4Editor-Cmd.exe -utf8output -platform=Win64 -client -build -cook -map=MainMap+NewMap -unversionedcookedcontent -pak -createreleaseversion=0.1.1 -compressed -stage -package -cmdline=" -Messaging" -addcmdline="-SessionId=F1B66F6F4B3B0483280DD69FF7326809 -SessionOwner='Simon' -SessionName='Release'"
 Automation.Process: Setting up command environment.
 CommandEnvironment.SetupBuildEnvironment: WARNING: Couldn't find installation of Visual Studio
 CommandEnvironment.SetupBuildEnvironment: WARNING: Assuming no solution compilation capability.
 BuildCookRun.SetupParams: Setting up ProjectParams for D:\Simon\Unreal Engine Projects\SlowMotionProj\SlowMotionProj.uproject
 Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Client target not found!
    at AutomationTool.ProjectParams.AutodetectSettings(Boolean bReset)
    at AutomationTool.ProjectParams..ctor(FileReference RawProjectPath, BuildCommand Command, String Device, String MapToRun, String AdditionalServerMapParams, ParamList`1 Port, String RunCommandline, String StageCommandline, String BundleName, String StageDirectoryParam, String UE4Exe, String SignPak, List`1 ClientConfigsToBuild, List`1 ServerConfigsToBuild, ParamList`1 MapsToCook, ParamList`1 DirectoriesToCook, String InternationalizationPreset, ParamList`1 CulturesToCook, ParamList`1 ClientCookedTargets, ParamList`1 EditorTargets, ParamList`1 ServerCookedTargets, List`1 ClientTargetPlatforms, Dictionary`2 ClientDependentPlatformMap, List`1 ServerTargetPlatforms, Dictionary`2 ServerDependentPlatformMap, Nullable`1 Build, Nullable`1 Cook, Nullable`1 Run, Nullable`1 SkipServer, Nullable`1 Clean, Nullable`1 Compressed, Nullable`1 UseDebugParamForEditorExe, Nullable`1 IterativeCooking, Nullable`1 IterateSharedCookedBuild, Nullable`1 CookAll, Nullable`1 CookPartialGC, Nullable`1 CookInEditor, Nullable`1 CookMapsOnly, Nullable`1 CookOnTheFly, Nullable`1 CookOnTheFlyStreaming, Nullable`1 UnversionedCookedContent, Nullable`1 EncryptIniFiles, Nullable`1 EncryptEverything, Nullable`1 SkipCookingEditorContent, Nullable`1 NumCookersToSpawn, String AdditionalCookerOptions, String BasedOnReleaseVersion, String CreateReleaseVersion, String CreateReleaseVersionBasePath, String BasedOnReleaseVersionBasePath, Nullable`1 GeneratePatch, String DLCName, String DiffCookedContentPath, Nullable`1 DLCIncludeEngineContent, Nullable`1 NewCook, Nullable`1 OldCook, Nullable`1 CrashReporter, Nullable`1 DedicatedServer, Nullable`1 Client, Nullable`1 Deploy, String DeployFolder, Nullable`1 FileServer, Nullable`1 Foreign, Nullable`1 ForeignCode, Nullable`1 LogWindow, Nullable`1 NoCleanStage, Nullable`1 NoClient, Nullable`1 NoDebugInfo, Nullable`1 NoXGE, Nullable`1 Package, Nullable`1 Pak, Nullable`1 Prereqs, String AppLocalDirectory, Nullable`1 NoBootstrapExe, Nullable`1 SignedPak, Nullable`1 NullRHI, Nullable`1 FakeClient, Nullable`1 EditorTest, Nullable`1 RunAutomationTests, String RunAutomationTest, Nullable`1 CrashIndex, Nullable`1 SkipCook, Nullable`1 SkipCookOnTheFly, Nullable`1 SkipPak, Nullable`1 SkipStage, Nullable`1 Stage, Nullable`1 Manifests, Nullable`1 CreateChunkInstall, Nullable`1 Unattended, Nullable`1 NumClients, Nullable`1 Archive, String ArchiveDirectoryParam, Nullable`1 ArchiveMetaData, Nullable`1 CreateAppBundle, ParamList`1 ProgramTargets, Nullable`1 Distribution, Nullable`1 Prebuilt, Nullable`1 RunTimeoutSeconds, String SpecifiedArchitecture, Nullable`1 IterativeDeploy, Nullable`1 FastCook, Nullable`1 IgnoreCookErrors, Nullable`1 RunAssetNativization, Nullable`1 CodeSign, Nullable`1 TreatNonShippingBinariesAsDebugFiles, String Provision, String Certificate, ParamList`1 InMapsToRebuildLightMaps, ParamList`1 TitleID)
    at BuildCookRun.SetupParams()
    at BuildCookRun.ExecuteBuild()
    at AutomationTool.BuildCommand.Execute()
    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
    at AutomationTool.Automation.Process(String[] Arguments)
    at AutomationTool.Program.MainProc(Object Param)
    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
    at AutomationTool.Program.Main()
 Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
 BUILD FAILED
 

If someone knows the problem, I'd really appreciate the help :)

Product Version: UE 4.15
Tags:
more ▼

asked May 21 '17 at 03:44 PM in Packaging & Deployment

avatar image

DefaltSimon
21 1 1 2

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I was getting frustrated, so I migrated my assets to a new blank project again. It worked! (not sure why)

However: if there's an explanation to this or a simpler fix, I'd still like to hear it.

more ▼

answered May 23 '17 at 04:10 PM

avatar image

DefaltSimon
21 1 1 2

avatar image corejake May 26 '18 at 02:31 PM

you just had to add it in VS, close the editor, rebuild and here you go!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question